Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Pontiac > Grand Prix
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 11-12-2010, 02:06 PM   #1
ktmccrary
AF Newbie
 
Join Date: Sep 2010
Location: Mooresboro, North Carolina
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
98 GTP SC HELP BNAYLOR! Compound Problem, Temp Gauge, More

I inherited a 1998 GTP 3800 Supercharged car with a host of problems. I've fixed most of them, but I have started replacing items that aren't fixing problems.
The temp gauge self-tests from 0 to max to 0 when I turn on the key, but the gauge never moves off 0 when the engine is running. I have an Actron scanner showing it running at normal temp. This model has a 3-pin (dual output sensor) which I replaced. At first I couldn't even get a reading on the scanner with the new sensor, but traced that to a bad connection in the connector. Now it's back where it was at 0 again.

I have multiple problems and believe they may all be related.

I was getting a p0102 MAF sensor error but traced it to fuse 21 in the underhood fuse panel. Replaced it, blew it and replaced it again. It seems to blow if I rev it above 3000 rpm, and then of course the rev limiter won't allow it to rev about 4000 RPM.

The transmission indicator on the instrument cluster only lights up park when it is in park or when it is in 3rd (stil lights up in park) , All other gears have no indicator light, nor are there any lights on the floor console indicating the gear it is in.

The oil level light comes on whenever the shifter is taken out of park, while the ign sw is on with the engine running or not. I replaced the oil level switch, cleaned the connector, to no avail.

Thus far I replaced the oil level switch, the temperature sensor, and even the instrument cluster, and have solved nothing.

I'm down to either having mouse-chewed wiring somewhere or possibly the PCM is bad. I at least avoided buying a $130 MAF sensor when I found the blown fuse, but I haven't found the cause of the blown fuse yet. Any and all help will be greatly appreciated.

Last edited by ktmccrary; 11-12-2010 at 02:09 PM. Reason: spelling
ktmccrary is offline   Reply With Quote
Old 11-12-2010, 02:39 PM   #2
grandprixgtx00
AF Enthusiast
 
grandprixgtx00's Avatar
 
Join Date: Feb 2008
Location: Stevens Point, Wisconsin
Posts: 989
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via AIM to grandprixgtx00
Re: 98 GTP SC HELP BNAYLOR! Compound Problem, Temp Gauge, More

I would venture to say you may have a bad ignition harness. However this is truly just a guess. We'll wait for a few other opinions
__________________


grandprixgtx00 is offline   Reply With Quote
Old 11-12-2010, 04:20 PM   #3
olopezm
AF Enthusiast
 
olopezm's Avatar
 
Join Date: Jul 2005
Location: Irapuato, Mexico
Posts: 1,456
Thanks: 149
Thanked 85 Times in 83 Posts
Send a message via MSN to olopezm Send a message via Skype™ to olopezm
Re: 98 GTP SC HELP BNAYLOR! Compound Problem, Temp Gauge, More

I'm not an expert but I agree with grandprixgtx00 but could this also be a bad ground problem? Have you checked them?

Best regards,

Oscar.
__________________
1995 Lincoln Town Car 4.6 Signature
1997 Pontiac Grand Prix GT 3.8
2000 Ford Windstar SE 3.8
olopezm is offline   Reply With Quote
Old 11-13-2010, 09:25 AM   #4
BNaylor
AF Moderator
 
BNaylor's Avatar
 
Join Date: Jan 2005
Location: El Paso, Texas
Posts: 18,017
Thanks: 30
Thanked 51 Times in 39 Posts
Re: 98 GTP SC HELP BNAYLOR! Compound Problem, Temp Gauge, More

Ignition switch/harness assembly is possible but I'd troubleshoot further to be sure.

Any other abnormal indications like headlights flickering, no cruise control, no fog lights, abs light on, HVAC issues, no turn signals, engine cutting off when using turn signals?



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
__________________

'08 Pontiac Grand Prix GXP (Dark Slate Metallic) - LS4 5.3L V8
'02 Oldsmobile Alero GL2 - LA1 3400 V6
'99 Buick Regal LS - L36 Series II 3800 V6
'03 Honda CR250R MX - 2 Stroke 250cc
'97 Pontiac Grand Prix GTP - L67 Series II 3800 V6 Supercharged (Sold)
Timeslip 08/12/06

AF Community Guidelines
BNaylor is offline   Reply With Quote
Old 11-13-2010, 09:39 PM   #5
tblake
In God We Trust
 
tblake's Avatar
 
Join Date: Nov 2003
Location: Maple Lake, Minnesota
Posts: 5,970
Thanks: 4
Thanked 22 Times in 21 Posts
Send a message via MSN to tblake
Re: 98 GTP SC HELP BNAYLOR! Compound Problem, Temp Gauge, More

I didn't know the guages self test on any 97-03 GP's. I thought that was just an 04+ thing. At least I know my temp guage wont start at 0, self test to max, and return to 0 when I start my car.
__________________
-2000 Grand Prix GTP 170,000mi (daily driver)
-2000 Olds Alero 100,000mi (soon to be DD with gas at $3.45/gal)
-1997 Chev K1500 4x4 115,000mi (Natalie's truck [nans_grandprix])


AF "2.0" Community Guidelines

Conservative Victory 2012!!!

"I'll Keep my Guns, Freedom, and Money. You can Keep the Change!"

----->>>>> Did You Know? <<<<<-----
tblake is offline   Reply With Quote
Old 11-13-2010, 10:53 PM   #6
BNaylor
AF Moderator
 
BNaylor's Avatar
 
Join Date: Jan 2005
Location: El Paso, Texas
Posts: 18,017
Thanks: 30
Thanked 51 Times in 39 Posts
Re: 98 GTP SC HELP BNAYLOR! Compound Problem, Temp Gauge, More

Quote:
Originally Posted by tblake View Post
I thought that was just an 04+ thing.
Yup actual IP gauge self-test is an '04 and up (final generation) thang.

I think what he meant is at ignition ON the gauge should at least go to what the ECT has for engine coolant temperature. In his case its dead or abnormal.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3
__________________

'08 Pontiac Grand Prix GXP (Dark Slate Metallic) - LS4 5.3L V8
'02 Oldsmobile Alero GL2 - LA1 3400 V6
'99 Buick Regal LS - L36 Series II 3800 V6
'03 Honda CR250R MX - 2 Stroke 250cc
'97 Pontiac Grand Prix GTP - L67 Series II 3800 V6 Supercharged (Sold)
Timeslip 08/12/06

AF Community Guidelines
BNaylor is offline   Reply With Quote
Old 12-01-2010, 04:41 PM   #7
ktmccrary
AF Newbie
Thread starter
 
Join Date: Sep 2010
Location: Mooresboro, North Carolina
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 98 GTP SC HELP BNAYLOR! Compound Problem, Temp Gauge, More

Sorry, slow to get back. Had to rebuild a freakin Saturn Engine. I actually did mean "self-test". When you turn the switch to the on position the temp gauge needle moves to max, then back to min where it remains even when the engine reaches operating temperature.
I have found some corrsion on both a pos and neg battery wire where it looks like it got into a pulley once upon a time. I need to investigate this further before pursuing other matters. I'll try to get back to you with results. Thanks. BTW this is a HUD model.
ktmccrary is offline   Reply With Quote
Old 12-02-2010, 10:34 AM   #8
tblake
In God We Trust
 
tblake's Avatar
 
Join Date: Nov 2003
Location: Maple Lake, Minnesota
Posts: 5,970
Thanks: 4
Thanked 22 Times in 21 Posts
Send a message via MSN to tblake
Re: 98 GTP SC HELP BNAYLOR! Compound Problem, Temp Gauge, More

pretty sure its not supposed to self test. i'd have to say you have a circuit problem causing it to max out when you turn the ignition on.
__________________
-2000 Grand Prix GTP 170,000mi (daily driver)
-2000 Olds Alero 100,000mi (soon to be DD with gas at $3.45/gal)
-1997 Chev K1500 4x4 115,000mi (Natalie's truck [nans_grandprix])


AF "2.0" Community Guidelines

Conservative Victory 2012!!!

"I'll Keep my Guns, Freedom, and Money. You can Keep the Change!"

----->>>>> Did You Know? <<<<<-----
tblake is offline   Reply With Quote
Old 12-02-2010, 08:37 PM   #9
grandprixgtx00
AF Enthusiast
 
grandprixgtx00's Avatar
 
Join Date: Feb 2008
Location: Stevens Point, Wisconsin
Posts: 989
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via AIM to grandprixgtx00
Re: 98 GTP SC HELP BNAYLOR! Compound Problem, Temp Gauge, More

Quote:
Originally Posted by tblake View Post
pretty sure its not supposed to self test.
__________________


grandprixgtx00 is offline   Reply With Quote
 
Similar Threads
Thread Thread Starter Forum Replies Last Post
1998 CVPI serious issue right now, need real help b4 i get raked for more $$$ Towboss1971 Crown Victoria 1 06-20-2010 12:39 PM
94 thunderbird radiator fan/ temp gauge problem frustrated by now Thunderbird 19 08-09-2009 12:05 PM
temp gauge and more...please help martini25 Cavalier 1 11-27-2007 02:41 PM
Help with the outside Temp gauge reading clark35 Town Car 3 08-02-2007 08:19 PM
99 Cavalier needs help (shucking action & temp. gauge stuck on cold) cass_17_7 Cavalier Problem Diagnosis 6 01-03-2006 03:10 PM

Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
gauge, level, oil, prnd321, temp
Go Back   Automotive Forums .com Car Chat > Pontiac > Grand Prix

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:25 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts