Our Community is 940,000 Strong. Join Us.


Mercury Mystique Mess


Moriah
08-02-2005, 01:40 AM
[COLOR=indigo]I have replaced the alternator, sensors, filters, oil, spark plugs, battery, spark plug wiring, I did the compression test { three times once with adding oil}
Spark Plug
#1 185 PSI
#2 200 PSI
#3 190 PSI
#4 190 PSI
Haynes repair manual isn't helping will still not start, turns over and is almost there even when hooked to another battery, Please any suggestions money tree in the back dried up.

beyondloadedSE
08-02-2005, 09:27 AM
have you replaced the crank position sensor?

Moriah
08-02-2005, 01:57 PM
No I didn't looking for one now thanks!!

Moriah
08-11-2005, 06:38 PM
[COLOR=indigo]I have replaced the alternator, sensors, filters, oil, spark plugs, battery, spark plug wiring, I did the compression test { three times once with adding oil}
Spark Plug
#1 185 PSI
#2 200 PSI
#3 190 PSI
#4 190 PSI
Haynes repair manual isn't helping will still not start, turns over and is almost there even when hooked to another battery, Please any suggestions money tree in the back dried up.

O.K. new question when you do a compression test how do you know if you need piston rings or the pistons themselves that are bad ?

beyondloadedSE
08-11-2005, 08:09 PM
the psi in the blown cylinder would be a lot lower than the good ones.

Moriah
08-12-2005, 05:19 PM
Thank you again so it is only the rings then? now my battery is getting to much power and I am trying to find the source of the sparking, but you have been really wonderful and helpful thanks again.

Add your comment to this topic!