Here's a strange one.


96SebringLXV6
07-31-2009, 08:46 PM
I have a 1996 Sebring Coupe with 194000 original miles on its 2.5l V6 SOHC (6G73) and on the original unrebuilt transmission, figure that out. Today I was driving around and I noticed it was sluggish in second gear, but only for a few seconds, then is start to go as usual. I also noticed when I was coming to a stop it began to idle up and down, between 100-600 rpms, I placed it in neutral and it stopped. It has never stalled and always starts first try. Any ideas? No leaks, no noises, no vibrations, no check engine light or anything else to indicate a problem. Any feedback on this would be appreciated, thanks.

96SebringLXV6
07-31-2009, 11:01 PM
Guess the problem is that bad, or maybe it is in my head!:sarcasm1:

javen6
09-18-2009, 09:02 AM
I am having similar issuse......on a 95 with a 2.5....I have changed the spark plugs, wires, TPS, Tep. sensor, cam or crank sensor, fuel filter, even the throttle body....still hesitation if ya gas it a little to hard. The next thing I am gonna do is the distributor:banghead::banghead:....good luck with yours...

braintech928
09-18-2009, 07:53 PM
my 2006 does that when the ac is on

mark44004
10-05-2011, 12:44 PM
Your clutch plates are gone and it's only a matter of time before you ain't moving. Time to either ditch the ride or if you absolutely love it then get it rebuilt (1600.00 or so) or replaced. I opted for the replacement with a rebuild I found for 550.00 out of a transmission repair facility in Cleveland, OH. 1-216-269-1494 (ships nationwide) Excellent folks and I've put 55,000 on the replacement tranny with no issues. I have 172000 on it now.

Add your comment to this topic!