1994 Trooper Issues

01-02-2008, 01:21 PM
I just purchased a used 1994 Trooper LS with 148,000 miles on it. Overall the vehicle is in good shape, but the more that I drive it I am finding some issues that are starting to concern me.

This is a 5-speed manual transmission with the 3.2L engine.

First thing I noticed was the U/S light on the dashboard. It seems to work fine as I shift through the gears, but then comes on and stays on when I am in 5th gear. Its almost like it thinks that I should have a 6th gear to go to.

Secondly, the cruise does not seem to work. I push the button to turn the cruise on and the cruise indicator on the dash does not come on and the cruise does not function. I have checked and I do not seem to find a fuse for cruise so I don't think that is the issue.

Lastly, I replaced one of the tail lights recently and when checking to make sure all the lights lit I noticed that the reverse lights do not come on when I put the car in reverse. However, this morning as I was leaving my driveway I happened to notice that my reverse lights do come on, but they come on when I shift into first and second gear. None of the other gears will light the reverse lights but first and second.

It seems ike all these issue are somewhat related and I am concerned that it is going to end up being something in the transmission. Does anyone have any ideas of where I should start to see if I can troubleshoot these issues? I am definately not a mechanic, but I have some access to some people who are so if its something I can resolve myself I would really like to do so.

Any insight would be appreciated.


01-03-2008, 12:30 AM
sounds like someone switched some of the connectors on the trans. there's a reverse light switch, and indicator switches for 1-2 and 3-4 and one or two others. crawl under there and see if you can figure out where the wires ought to be by their lenght and position.


Add your comment to this topic!