Our Community is 705,000 Strong. Join Us.


Subaru Transmission Problem


eaf3576
01-11-2007, 05:57 PM
Hi All,

Just wanted to run my problem past you guys. When my 1995 Legacy is cold the auto transmission will not shift past 2nd gear. Once it warms up... after 10 mins or so I get 3rd and 10 mins after that I get 4th with lock up converter. Any ideas?

Eric

freakray
01-11-2007, 06:11 PM
Checked the fluid level?

escapingoth
01-11-2007, 07:28 PM
Hi All,

Just wanted to run my problem past you guys. When my 1995 Legacy is cold the auto transmission will not shift past 2nd gear. Once it warms up... after 10 mins or so I get 3rd and 10 mins after that I get 4th with lock up converter. Any ideas?

Eric

If you are full. Is there any burnt smell from the fluid. First thing I do usually if I do have problems with an auto is change the fluid.

Hans

sha_zapple
01-16-2007, 01:00 PM
The transmission is programmed to stay below 3rd gear until it reaches a certain operating temperature. 10 minutes seems a bit excessive. Are you sure its in 2nd?
Id try a fluid change as the others suggested since it probably needs one anyway.

eaf3576
02-01-2007, 03:08 PM
Thanks for the response all. Yes the fluid was changed about 6 months ago when the problem began in the summertime... (not getting 4th gear until warm). Fluid level is good. The cold tempertures have seemed to made the problem worse... (holding in second gear until warm).

freakray
02-01-2007, 04:06 PM
Help me out here, was the 1995 Legacy AT with the cable shift or hydraulic?

Add your comment to this topic!