91 Legacy OIL light


baffled24
09-18-2006, 07:38 PM
I just bought a 91 Legacy 3 days ago with 125k on it. Everything seemed fine until yesterday when the oil light came on after the car had warmed up. I took it to a local mechanic, and the only way he could get it to go off was to set my rpms high enough that they won't drop below 1200 when in gear.

The car is now parked until sometime 'next week' when they can look into it further. I really need this car for work but I am pretty sure that idling at 2000 rpm and 1300 rpm when engaged is not doing the car any good either. I am thinking oil pump, but am far from a mechanic. Besides I think the local mechanic should have been able to tell me that in the time he spent on it today?...

Any help is much appreciated.

Thx

Bizzy102
09-21-2006, 08:57 PM
nnumber one.. Check your oil.. If that checks out okay, take you pcv valve and make sure it is clear. Sometime , if you have a clogged pcv it could make you oil pressure drop..

baffled24
09-25-2006, 03:07 PM
Thx I will check that, I have also been told it could be the oil sending unit. Also someone said the 5 screws in the 'plate' in the oil pump have a tendency to back out sometimes...

StNicholas
09-25-2006, 03:57 PM
In addition to the previous, have the mechanic install a mechanical oil pressure gauge in place of the sending unit to see if there is sufficient oil pressure.

I hope it is simple and inexpensive repair.

Nick

baffled24
09-25-2006, 04:43 PM
I hope so too, I just called my main mechanic and he said 9 out of 10 times it is the bearings, and the motor may be shot. Taking it to him tonight. I just bought the car, so I hope this is the 1 time that it's not the bearings.

He said he will check the sending unit, pcv, pump, etc. But didn't seem very optomistic.

Add your comment to this topic!