ignition problem


mcarthen
07-23-2015, 08:40 PM
my 2001 chevy impala keeps blowing ignition fuses in the fuse box under the hood. i turn the switch and the fuse will blow. it use to just blow on occasion but now as soon as i turn the switch it blows so now the car won't crank at all. had the plugs and wires done and also have a new starter and alternator installed and a new battery. only one fuse is blowing (15A)

Tech II
07-24-2015, 08:37 AM
What is the exact fuse ? Name? Number?

mcarthen
07-25-2015, 10:51 AM
It is in the lower box and is a 15 amp fuse that says fuel inj ( i guess it's short for injection).

Tech II
07-25-2015, 11:45 AM
My fault....should have asked which engine size...3.1, 3.4, 3.5, or 3.8L....

This is for a 3.8.....If the fuse blows as soon as you turn the ignition on, disconnect all injectors.....now turn the key on...if it still blows, you have a wiring problem before the injectors...follow the harness to look for chafing anywhere....

If it doesn't blow, turn key off, now attach one injector....turn key on and see if the fuse blows...if it doesn't, then turn key off, and attach another and turn key on again....do this until you find the bad injector...

If this is a 3.1/3.4, mice are known for making a nest under the upper plenum, and eating the insulation of the wires going to the injectors, and causing them to short out....

http://repairguide.autozone.com/znetrgs/repair_guide_content/en_us/images/0996b43f/80/24/49/48/large/0996b43f80244948.gif

mcarthen
07-25-2015, 03:00 PM
I should have said also but it is a 3.8L and also where do I disconnect this wiring harness to perform this test...

Thank you

mcarthen
07-25-2015, 03:12 PM
are the injector plugs on top of the motor along side the intake?

Tech II
07-25-2015, 08:44 PM
On a 3.8, remove the plastic engine cover....then follow the fuel lines to the fuel rail that goes around the upper plenum....you will see the 6 harnesses going to the injectors in the fuel rail....

mcarthen
07-25-2015, 09:44 PM
ok I know the harness your talking about it has six plugs one on each injector i will try it tomorrow evening and let you know what happens

mcarthen
07-25-2015, 09:48 PM
i know the harness I will do the test tomorrow and let you know the results

j cAT
07-27-2015, 04:38 PM
i know the harness I will do the test tomorrow and let you know the results

rather than remove the injector plug to the injector , follow the wiring back to the fuse box look for damaged wire from the engine . since you had this problem before and the engine ran good the injectors are fine it is a bad feed wire from the fuse to the engine where the wires break out to all the injectors. as soon as the key is to on NO CRANKING power is then to all the injectors... PCM makes the ground connection to turn on the injectors so that is not the problem.

Tech II
07-28-2015, 10:22 AM
jcat, didn't I say that?

j cAT
07-28-2015, 12:40 PM
jcat, didn't I say that?

this is what I saw you said "If the fuse blows as soon as you turn the ignition on, disconnect all injectors " this is why I said , do not disconnect the injectors ,just follow the wires back from the injectors to the fuse box first .. see whats broke.. he was going to see what injector was blowing the fuse , from his going to test this out remark by removing the injector feed wires. many novices will break the injector connectors .

Tech II
07-28-2015, 07:37 PM
"If the fuse blows as soon as you turn the ignition on, disconnect all injectors.....now turn the key on...if it still blows, you have a wiring problem before the injectors...follow the harness to look for chafing anywhere...."

By doing this you verify if it's the injectors or the harness.....but you are right about the injector connectors....some are tricky to disengage....

mcarthen
07-30-2015, 01:21 PM
The engine is turning over but will not crank outside now looking for cracked and worn out wiring.

mcarthen
07-30-2015, 07:22 PM
Sending the car to a service center, to many wires for me to trace and look at.

j cAT
07-31-2015, 01:20 PM
Sending the car to a service center, to many wires for me to trace and look at.

the only wire your going to trace back is the PINK WIRE !!!!!. all the injectors have this wire to all 6 of them................same wire in parallel,,,then it goes back to the fuse box .. if your color blind then best have the repair shop do it..

Add your comment to this topic!