Weird Starting Problem


yackmaster
11-26-2010, 10:21 PM
p { margin-bottom: 0.08in; } Issue: Truck will not turn over after sitting for 2-3 hours or overnight.
Truck Specs:
98 Passport
206,000 miles
Original Drive Train - working fine
Everything is bone stock.


Here are the details.
A few months ago the truck started to not turn over when I turned the key. Usually this happened once or twice and then it would start. As time has gone by this has gotten worse. It got to the point if I turned the key slowly it would start on the first try. This has ceased to work. This is always the case now if the truck sits for 2-3 hours or overnight.


Now I have to disconnect the Neg battery cable for 15-30 seconds, reconnect and after 4-6 tries it will start. If I'm driving the truck around town I can let the truck sit for 40-60 mins while I'm shopping, come back and it will start on the first try.


I thought it might be the starter but it when it cranks over it is a strong start, plus I never have gotten the classic clicking noise of the starter trying to engage. The battery is new, the alternator is charging fine. I also wonder if the key cylinder might be going bad.


I do have the CEL come on and off. Usually the codes are EGR (replaced the EGR valve 5 times and tried to clean out the tube in the manifold), Evap codes (have not has a smoke test done yet but vacuumn pressure in “ZERO” in gas tank when removing gas cap. Did replace gas cap with no effect.), and a TPS code (replaced 5 times and went back to original bad part to cure high idle issue)


Either way I'm on my last straw. Any help would be great and thanks in advance.

Add your comment to this topic!