Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Windstar
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools
Old 09-03-2010, 02:11 PM   #1
kafkacell
Fooling around
 
Join Date: Aug 2010
Location: Willemstad
Posts: 66
Thanks: 2
Thanked 2 Times in 2 Posts
Red face IAC Windstar 96, 3.8 and other issues.

Hi, first post here. I just bought a Windstar 1996 3.8 with 144k miles on it (KM?).

It has several issues, but now Im just worried about fixing the safety issues.

Rear view mirror at drivers side is broken, so I need to put it off, and take it to the store and them will put the mirror. I've tried to unninstall it, but failed. I only see a nut and after removing it i don't see a way to take it out.

If someone could share some pictures or guidelines about how to remove it, I'd really appreciate it.

I bought it because it was a bargain (here at Netherlands Antilles it could cost like 3500$, and I got it for only 500$).

I've changed by myself: fuel filter, cleaned injectors (dirty as hell), cleaned EGR, cleaned IAC, cleaned spark plugs (they are not so bad), cleaned MAF. I've read and followed the instructions proposed here at the forum (I have been reading a lot this forum since I bought the van)

I'm sure IAC valve is bad, since every time I turn at very slow speed it just dyes.

I've checked spark plug cables and yes, one is bad.

O/D light is flashing almost every time. I have no ABS light after started the car. Speedo doesn't work either (I've checked lower cable and it's not connected to the other part of the cable).

There is no caliper at passengers side, so Im only using one wheel breaks (wow).

Anyway, I don't have the money now to fix every thing I want, but I'd like to fix the safety issues first (rear view mirror, caliper, and get a new IAC valve).

Today I went to a junkyard here, and there are no parts for this car here. My only choice is Napa. I've asked for IAC and Caliper and each one will cost me 130/150 bucks (yikes!). For now it's just impossible to get those. But for only 17$ I can get the rear view mirror fixed.

If somebody knows how to remove it, please let me now asap.

Regards, and thanks in advance.

PD I really like the van, and i'd like to fix everything and keep it for a long time.

Last edited by kafkacell; 09-06-2010 at 11:58 AM. Reason: First issue fixed... few lefts.
kafkacell is offline   Reply With Quote
Old 09-04-2010, 08:17 AM   #2
phil-l
AF Enthusiast
 
Join Date: Oct 2005
Location: Columbia, Maryland
Posts: 809
Thanks: 25
Thanked 33 Times in 32 Posts
Re: Rear view mirror installation

kafkacell -

Best wishes with your Windstar - in a place where parts are hard to come by!

You probably don't need a new IAC: It usually responds well to cleaning.

Take a look at this for a good IAC cleaning procedure:

http://leckemby.net/windstar/windstar02.html

Sorry, I haven't removed a mirror on mine. I'll leave that question to others...
__________________
2000 Windstar LX 3.8
1995 Contour GL 2.5
1986 Mustang GT 5.0 --> Sold, but missed on sunny days
phil-l is offline   Reply With Quote
Old 09-04-2010, 12:53 PM   #3
kafkacell
Fooling around
Thread starter
 
Join Date: Aug 2010
Location: Willemstad
Posts: 66
Thanks: 2
Thanked 2 Times in 2 Posts
Re: Rear view mirror installation

Thanks for your reply, today I finally figured out how to remove it. There were two rubbers covering two nuts more... my bad.

I've cleaned a couple of times IAC valve, first using carb cleaner, and the last oen using WD-40 but didn't wait 15 minutes as is suggested.

Btw, mine doesn't have a gasket. Is it normal? I only see two small white/blue rubbers in the throattle body. Yesterday I've asked at Napa for the gasket, and they don't have it here. My old Mercury Tracer 95 did have a gasket in the IAC.

I'll find another can of WD-40 and try again.

Thanks again, and the rear view mirror will be fixed next week (the will put the mirror).

regards
kafkacell is offline   Reply With Quote
Old 09-05-2010, 05:32 AM   #4
kafkacell
Fooling around
Thread starter
 
Join Date: Aug 2010
Location: Willemstad
Posts: 66
Thanks: 2
Thanked 2 Times in 2 Posts
Re: Rear view mirror installation

Small update:

I've cleaned the IAC again, used WD-40 for about 35 minutes. Went out a while, and a couple of times while parking the engine stalled. So far no changes on this.

Quoting Wsiwind:
‎"A common symptom of the IAC not working correctly is engine stalling in
parking lot manuvers, when your foot is not on the accellerator and you
are turning the steering wheel"




By monday i will try cleaning again, but this time I will try one hour of more. I tried to move carefully the spring inside and it's really hard. Dunno if someone can confirm this, but I assume it shouldn't be hard to move at all.

Regards
kafkacell is offline   Reply With Quote
Old 09-06-2010, 12:04 PM   #5
kafkacell
Fooling around
Thread starter
 
Join Date: Aug 2010
Location: Willemstad
Posts: 66
Thanks: 2
Thanked 2 Times in 2 Posts
Updates

OK, rear view mirror is fixed.

Today I took out IAC Valve. Put it first carb cleaner on it for about 1 hour. Then put it WD-40 on it for about 2 hours. Cleaned all (Throttle body had some oil which came from air filter) and put it back.

Tested some stops, parking lot manuvers, and engine didn't die. I can't be sure if it's fixed, but today it responded better at stops. I will test it later and will confirm if it was just dirty.

Regards and thanks for helping.

PD now to work on the other issues.
kafkacell is offline   Reply With Quote
Old 09-15-2010, 09:38 PM   #6
kafkacell
Fooling around
Thread starter
 
Join Date: Aug 2010
Location: Willemstad
Posts: 66
Thanks: 2
Thanked 2 Times in 2 Posts
one week later IAC is worst

Ok, one week passed, and my Windstar started to stall again, even at starting it just dies. RPM at starting go to 1200 and then went down to 200 RPM and instantly dies.

I cleaned again, but failed to start. I've checked electricty on connector: it's ok. Also disconnected IAC with engine running and nothing happened (last week it stalls after disconnecting the IAC), but today nothing happened. This lead me to think tha IAC is dead.

Someone sent us some money to buy the part (that's why I cleaned so hard), and hopefully napa store will have it.

Tomorrow I'll buy it and will give some updates.

Regards.
kafkacell is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Tags
1996 , 3.8l , rear , viewmirror , windstar
Go Back   Automotive Forums .com Car Chat > Ford > Windstar

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:33 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts