Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Blazer > Problem Diagnosis
Problem Diagnosis Got a problem you can't fix? Post here and one of our members will answer as soon as possible.
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools
Old 04-02-2007, 10:34 PM   #1
georgie95020
AF Newbie
 
Join Date: Apr 2007
Location: Gilroy, California
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Question i replaced the water pump,but now the bely or pully squeaks

the water pump on my 97 chevy blazer has just went out, so i got the instruction from this site on how to replace it. keep in mind that the truck was sitting for about 3 years and from the time i started drivivg it until the time that the water pump went out the noter sounded great and run really good. so i went down to autozone and bought the parts and that special tool to take off the cluch plate, and i replaced the water pump but now when i start the truck it makes a squeakimg sound like the belt was slipping but now im thinking that maby when the water pump went out the first time and the rusty water shoot out all over the place it might of made one of the pullys a little squeaky... can someone help me please
georgie95020 is offline   Reply With Quote
Old 04-03-2007, 12:05 AM   #2
DelCoch
AF Regular
 
DelCoch's Avatar
 
Join Date: May 2005
Location: Middle of Nowhere
Posts: 435
Thanks: 0
Thanked 2 Times in 2 Posts
Re: i replaced the water pump,but now the bely or pully squeaks

Make sure you got the belt on right, with all the little grooves lined up. Next, take the belt off, bend it backwards and see if it has any stress cracks on the inside of the belt that run across the grooves, if so replace it. Also, with the belt off, check the pulleys to see if they feel rough when turning them by hand (bad bearing) or if they are loose or wobble.
DelCoch is offline   Reply With Quote
Old 04-03-2007, 12:21 AM   #3
georgie95020
AF Newbie
Thread starter
 
Join Date: Apr 2007
Location: Gilroy, California
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: i replaced the water pump,but now the bely or pully squeaks

thank you ill make sure to tay that with the belt but about the pullies i remember that the pully with the spring on it. i think its called the tension pully, its hold the belt on tight but it looks and feels a little lose but the bolt on it is tight. what do u think about that.
georgie95020 is offline   Reply With Quote
Old 04-03-2007, 12:49 AM   #4
DelCoch
AF Regular
 
DelCoch's Avatar
 
Join Date: May 2005
Location: Middle of Nowhere
Posts: 435
Thanks: 0
Thanked 2 Times in 2 Posts
Re: i replaced the water pump,but now the bely or pully squeaks

If in doubt I would replace the tension pulley, maybe the whole tension unit. They are not high dollar. But, check the other things also. You could have more than one problem. Also, try to turn the alternator fan and pulley with the engine off. If the pulley slips on the belt it is too loose (bad or broken spring in tension pulley) or the belt is glazed and must be replaced.
DelCoch is offline   Reply With Quote
Old 04-03-2007, 05:56 AM   #5
muddog321
AF -Advisor
 
Join Date: Jan 2006
Location: merritt island, Florida
Posts: 661
Thanks: 0
Thanked 2 Times in 1 Post
Re: i replaced the water pump,but now the bely or pully squeaks

Also check the idler pulley and that alternator - been sitting so....
muddog321 is offline   Reply With Quote
Old 04-04-2007, 04:15 PM   #6
someguy000001
AF Newbie
 
Join Date: Feb 2004
Location: Santa Barbara, California
Posts: 75
Thanks: 0
Thanked 0 Times in 0 Posts
Re: i replaced the water pump,but now the bely or pully squeaks

Quote:
Originally Posted by georgie95020
thank you ill make sure to tay that with the belt but about the pullies i remember that the pully with the spring on it. i think its called the tension pully, its hold the belt on tight but it looks and feels a little lose but the bolt on it is tight. what do u think about that.
On my '97 I had to replace the tensioner arm a few years ago and I just replaced the tensioner pulley a few months ago. My OEM tensioner fell apart one day, and the replacement is a different design.
Also, if it sat for 3 years it's time to replace the belt. Check the pulleys while it's off.
someguy000001 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Chevrolet > Blazer > Problem Diagnosis

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:16 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts