Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > GMC > Sierra
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools
Old 04-14-2024, 08:43 AM   #1
motorsports12
AF Newbie
 
Join Date: Jul 2009
Location: englewood, Ohio
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Cool 2500hd thermostat

I had a radiator leak and while I had it tore down I figured go ahead and change the thermostat ... A bolt broke so I ended up tearing it all the way down removing the water pump ... water pump, new hoses, new thermostat, new radiator ... after getting it all back together and filling with new antifreeze I fired it up let it idle ... heat on high ... reved it to 2500 rmps a couple of times ... let it idle... the gauge went to 210 but it always ran at 210 (thermostat is a 187) ... heres my issue ... upper radiator hose gets real hot but the bottom hose never did while it was running ... Im getting great heat out of the vents ... I shut it off and ate dinner went back out no change upper hose hot bottom still cool ... go through the whole thing again ... heat on, rev to 2500 rpm a couple of times, good heat through the vents, gauge is at 210 ... the hose are still the same ... it like the thermostat isnt opening ... then I clean up all my tools and the garage (bout an hour and a half) and check the hoses and now the bottom hose is the same temperature as the top hose ... did the thermostat open? did I get all the air out of the system? is the thermostat bad? I really dont want to tear it all down again ... any help would be appreciated
motorsports12 is offline   Reply With Quote
Old 04-14-2024, 08:51 AM   #2
motorsports12
AF Newbie
Thread starter
 
Join Date: Jul 2009
Location: englewood, Ohio
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2500hd thermostat

2012 GMC 2500HD WT with the 6.0 flex engine

Last edited by motorsports12; 04-14-2024 at 11:56 AM.
motorsports12 is offline   Reply With Quote
Old 04-14-2024, 10:25 PM   #3
Stealthee
Your worst nightmare
 
Stealthee's Avatar
 
Join Date: Oct 2004
Location: Smithfield, Pennsylvania
Posts: 6,061
Thanks: 40
Thanked 252 Times in 246 Posts
Re: 2500hd thermostat

Sounds like you had an air pocket. Sometimes they are just stubborn.
__________________
Stealthee is online now   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > GMC > Sierra

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 08:19 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts