Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Bronco
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools
Old 04-05-2013, 10:09 AM   #16
kohn261
AF Newbie
 
Join Date: Apr 2013
Location: girard, Ohio
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up Re: Beware Of The Bronco 2 Curse!!!!!

kohn261 is offline   Reply With Quote
Old 07-23-2013, 08:39 PM   #17
tjay242
AF Newbie
 
Join Date: Jul 2013
Location: Glenwood Springs, Colorado
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Beware Of The Bronco 2 Curse!!!!!

This sounds like what happened to my 87 Bronco II about 15 years ago. I would be driving down the highway after the engine was fully warmed up and it would sputter and cut-out until it would come to a complete stall. Would turn on engine after several minutes and start the whole process over again. It was the ignition module!! When I had that changed out it never did that again and has been running great ever since, 380,000 miles later.
tjay242 is offline   Reply With Quote
Old 04-01-2014, 03:17 PM   #18
theshoe05
AF Newbie
 
Join Date: Apr 2014
Location: San Antonio, Texas
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Beware Of The Bronco 2 Curse!!!!!

Hey everyone, so I had a similar issue with my 86 Bronco 2, the way I fixed my truck was by bypassed a fuel filter underneath the driver seat. I think there was a loss of fuel pressure and after this repair, I have not had this issue since (5 months).
Attached Images
File Type: jpg Scianceplace-BII162.jpg (149.3 KB, 1 views)
theshoe05 is offline   Reply With Quote
Old 09-16-2014, 04:51 PM   #19
gomerjrk
AF Newbie
 
Join Date: Sep 2014
Location: Harrison city, Pennsylvania
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Beware Of The Bronco 2 Curse!!!!!

Yea i got a 1986 broco 2 2.9 and its been sittin in a garge for 10 Years and i got it for 300$ and starts and runs but it pours white smoke i don't no y? can any one give me some tips
gomerjrk is offline   Reply With Quote
Old 09-16-2014, 05:31 PM   #20
Crvett69
AF Moderator
 
Crvett69's Avatar
 
Join Date: Oct 2004
Location: Bellingham, Washington
Posts: 1,751
Thanks: 0
Thanked 73 Times in 73 Posts
Re: Beware Of The Bronco 2 Curse!!!!!

white smoke is usually water, is oil milky looking or bottom side of oil fill cap white? might also want to run a compression test. think the 2.8 and 2.9 had head gasket and head cracking issues
Crvett69 is offline   Reply With Quote
Old 09-16-2014, 09:36 PM   #21
gomerjrk
AF Newbie
 
Join Date: Sep 2014
Location: Harrison city, Pennsylvania
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Beware Of The Bronco 2 Curse!!!!!

No the oil has no water in it don't know if the valves are stuck or rings it smell s like its burning oil
gomerjrk is offline   Reply With Quote
Old 10-04-2014, 09:35 PM   #22
baldwin3rd
AF Newbie
 
Join Date: Oct 2014
Location: Tucson, Arizona
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Beware Of The Bronco 2 Curse!!!!!

Mine was blowing black smoke changed a lot of emission parts. didnt work. Ened up being the catalytic converter.
baldwin3rd is offline   Reply With Quote
Old 12-12-2014, 08:06 PM   #23
Tmartin
AF Newbie
 
Join Date: Dec 2014
Location: Eagle, Idaho
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Beware Of The Bronco 2 Curse!!!!!

DEFECTIVE EGR VALVE IS THE PROBLEM : )
I have an 87 Bronco II with 2.9 V6. Was having same warm up and stammer and sputter with loss of power. I did everything - plugs, wires, IACV, TPS, etc.

Had hunch it was a defective EFR valve. Tested the problem by placing a metal plate (made from cutting up an aluminum pop can) between EGR valve and intake. This prevented any exhaust gas being able to be recirculated back into the intake improperly. VIOLA!! FIXED PROBLEM!!

Stupid EGR was stuck open and choking car with too much recirculated exhaust gas. This was making the car sputter due to lack of oxygen and the car' s computer was doing its best to compensate the proper fuel air mixture but just ended up running way too rich and stinky.

Good luck.
Tmartin is offline   Reply With Quote
Old 07-28-2015, 10:13 PM   #24
mikey@12
AF Newbie
 
Join Date: Jul 2015
Location: henerson, Nevada
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Beware Of The Bronco 2 Curse!!!!!

Has anyone checked. The fuel reg. It has a rubber diophram in it that can go bad and srrart to dry up and leak fuel. Iit happened to me. It spit out black smoke and raw fuel ran like crap. Had it towed into my mechanic and he knew what it was right of the bat. It toasted the cat. Converter but that was an easy fix. Im not sayin this is your problem but it is the only problem i had with my 86.
mikey@12 is offline   Reply With Quote
Old 09-13-2015, 04:34 PM   #25
80cobra
AF Newbie
 
Join Date: Sep 2015
Location: E bethel, Minnesota
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Beware Of The Bronco 2 Curse!!!!!

Shot gunning pArts and sensors to a problem is amateur at best. Bronco 2 tfi ignition systems were notorious for multiple problems ranging from over heating to losing ground. Another problem was the pins I. The plastic fuel pump connector had plastic melted contacts these contacts were prone to breaking especially 86 and 87 with dual pump set ups. The pins would push down into the tanks and not plug into the connector.
80cobra is offline   Reply With Quote
Old 03-31-2021, 01:15 PM   #26
Rodderson
AF Newbie
 
Join Date: Mar 2021
Location: North Edwards, California
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Beware Of The Bronco 2 Curse!!!!!

After replacing everything electrical on my 88 b2 I realized AutoZone sold me an incorrect icm. I was about to go nuts before I found it. Compare new and old parts inside and out.
Rodderson is offline   Reply With Quote
Old 11-22-2023, 11:05 PM   #27
marty91901
AF Newbie
 
Join Date: Mar 2022
Location: Alpine, California
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: Beware Of The Bronco 2 Curse!!!!!

This is my first post ever. I ran across this post several years ago and just feel I need to chime in given my experience with my '87 Bronco II. I too had the "curse" where it would run fine in open loop but stumble and sputter once it warmed up and went to closed loop mode. Switching the key momentarily off then back on would give me a few seconds of normalcy then back to the sputtering again. I must credit this fix to an old post I ran across by Richard McCuistian of "Ask a Mechanic" fame.
In days of old, with three wire O2 sensors, the ground for the 1 volt signal has to travel up the exhaust pipe, through the manifold and bolts into the head, where the orange wire is fastened that leads to the PCM. Its a long way for that 1 volt signal to travel and the message to the PCM gets corrupted. In my case after fighting this for two years, I fastened a hose clamp around the base of the O2 sensor then attached a wire from the clamp up to that orange wire via a Scotch Bloc thpe connector. Worked like a charm for me. Give it a try. Hope this helps someone.
Just an aside, it gets hot down there so I attached my wire to the 'excess" end of the hose clamp with a screw and nut. Its a little cooler an inch or so from the sensor itself. Thank goodness for 4 wire O2 sensors nowadays.
marty91901 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Ford > Bronco

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:00 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts