Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Honda > General Discussion
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools
Old 05-25-2023, 11:30 AM   #1
rp2121
AF Newbie
 
Join Date: May 2023
Location: Schenectady, New York
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
HONDA PILOT 2005 ALternator?

My 2005 Pilot is clicking when attempting to start it. The battery is new, the alternator was replaced 4 years ago and the starter was replaced 3 years ago. The car will not take a jump.
Any thoughts??

Thanks so much!
rp2121 is offline   Reply With Quote
Old 05-25-2023, 03:55 PM   #2
aleekat
AF Enthusiast
 
Join Date: Dec 2001
Location: clarksville, Tennessee
Posts: 1,698
Thanks: 23
Thanked 183 Times in 179 Posts
Re: HONDA PILOT 2005 ALternator?

You need to put a voltmeter on you battery. Static then cranking voltage reading. And if you get it running, running reading. Sounds like your alternator not charging and killed your battery. A really depleted battery you won't be able to jump.
__________________
Post back, that's what makes Forums Work.
aleekat is offline   Reply With Quote
Old 05-25-2023, 05:03 PM   #3
rp2121
AF Newbie
Thread starter
 
Join Date: May 2023
Location: Schenectady, New York
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: HONDA PILOT 2005 ALternator?

Thanks for the response.
If i put a new battery in and it still doesn't take a jump it wouldn't be the alternator correct? A bad alternator should at least take a jump even if it dies quickly?
rp2121 is offline   Reply With Quote
Old 05-25-2023, 05:48 PM   #4
Stealthee
Your worst nightmare
 
Stealthee's Avatar
 
Join Date: Oct 2004
Location: Smithfield, Pennsylvania
Posts: 6,046
Thanks: 36
Thanked 251 Times in 245 Posts
Re: HONDA PILOT 2005 ALternator?

Check your connections. Make sure you have good grounds.
__________________
Stealthee is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Honda > General Discussion

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:01 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts