Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Avalanche | C&K | Silverado | Suburban | Tahoe > Suburban
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools
Old 10-17-2020, 06:06 PM   #1
Ed G.
AF Newbie
 
Join Date: Oct 2020
Location: Lyons, Colorado
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
89 Suburban electrical issue.

I keep blowing ECM IGN 10 amp fuse when key turned to On. Engine cranks fine and disconnecting all engine sensors does not help. Tried removing all fuses and still get my test light to lite up across the ECM fuse contacts when key to On. Been all over wiring - nothing obvious?
Ed G. is offline   Reply With Quote
Old 10-18-2020, 10:46 AM   #2
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 6,507
Thanks: 6
Thanked 339 Times in 335 Posts
Re: 89 Suburban electrical issue.

You can also disconnect the wire harness at the injector pod, and check the connections to the EVAP purge solenoid, and the EGR solenoid.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
Old 10-18-2020, 11:39 AM   #3
Ed G.
AF Newbie
Thread starter
 
Join Date: Oct 2020
Location: Lyons, Colorado
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 89 Suburban electrical issue.

Thanks Blue Bowtie. I will try your suggestions. Ed G.
Ed G. is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Chevrolet > Avalanche | C&K | Silverado | Suburban | Tahoe > Suburban

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:44 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts