Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Avalanche | C&K | Silverado | Suburban | Tahoe > Suburban
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools
Old 07-02-2018, 08:34 AM   #1
rdharley3
AF Newbie
 
Join Date: Sep 2005
Location: Jeffersonville, Indiana
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
03 tranny fluid leak problem

On my 03 1500 suburban 4x4 the tranny finally gave up at 249k. I had a rebuilt tranny installed and after about 1k miles I'm driving down interstate look ;in my rear view mirror and smoke is rolling out of the rear of the truck I look like a crop duster going down the road. I stop check under the vehicle and tranny fluid is raining down from the bell housing area onto the exhaust I get back in notice my tranny temp is about 20 degrees hotter than normal so I put it in gear and limp to the next exit about 2 mile the tranny shifts normally the only difference is fluid 20 degrees hotter once I get off exit while waiting for tow truck I look under truck with engine running from bellhousing back is covered in tranny fluid but I see no fluid leak anywhere. any ideas on what's going on here?
rdharley3 is offline   Reply With Quote
Old 07-02-2018, 08:47 PM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,941
Thanks: 25
Thanked 369 Times in 363 Posts
Re: 03 tranny fluid leak problem

Tough here to suggest a source of the leak without an onsite inspection. Cooler lines are one possibility.
__________________
maxwedge is offline   Reply With Quote
Old 07-03-2018, 03:10 AM   #3
brcidd
AF Enthusiast
 
brcidd's Avatar
 
Join Date: Jul 2005
Location: troy, Ohio
Posts: 2,311
Thanks: 2
Thanked 171 Times in 169 Posts
Re: 03 tranny fluid leak problem

Just about always a cooler line- corroded and broke- same thing happened on my Dually....had to splice in a temporary hose fitting until I could get home and replace the entire lines.
__________________
Automotive A/C Engineer with:
'99 IH 4700 Toy Hauler
(2) '95 GEO Prizms both maroon
'99 GMC Yukon
'95 Chev 3500, 454 Dually Crew Cab- 145k miles-
Wife's Camel trailer puller.
'94 Astro- 370k miles
'94 Firebird Formula- 5.7L 180k miles- gone-
'92 Chevy Lumina Van 3.8L 264k
'86 GMC S-15 - 2.8L 154k
'87 Buick Park Ave . 187k
'86 Buick Park Ave 3.8L 199k miles- gone
'77 Chevy Vega- 2.5L 175k miles gone but not forgotten
'68 Camaro 396 4 spd RS/SS -72k miles-
brcidd is offline   Reply With Quote
Old 07-03-2018, 07:45 AM   #4
Blue Bowtie
Registered Offender
 
Blue Bowtie's Avatar
 
Join Date: Mar 2006
Location: Rural
Posts: 6,507
Thanks: 6
Thanked 339 Times in 335 Posts
Re: 03 tranny fluid leak problem

With a fresh rebuild and hot trans, it could also be the vent line burping oil.
__________________
Permanent seat assignment on the Group W bench...
Automotive Forums Survival Guide
Blue Bowtie is offline   Reply With Quote
Old 07-03-2018, 12:28 PM   #5
rdharley3
AF Newbie
Thread starter
 
Join Date: Sep 2005
Location: Jeffersonville, Indiana
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 03 tranny fluid leak problem

Ok here is what I did yesterday after truck sat all night checked fluid nothing on stick filled fluid back up to full it took 1 quart got underneath truck wiped down all traces of fluid with truck running did not see a leak anywhere put cardboard underneath let truck run for 20 minutes there is a slight leak coming somewhere on passenger side above exhaust crossover pipe I cannot tell where it is coming from as the only drip I see is underneath pipe on passenger side of truck.
rdharley3 is offline   Reply With Quote
Old 07-27-2018, 03:24 PM   #6
j cAT
AF Fanatic
 
Join Date: Oct 2007
Location: EVERETT, Massachusetts
Posts: 10,898
Thanks: 8
Thanked 432 Times in 431 Posts
Re: 03 tranny fluid leak problem

if has happened before after a tranny job the fluid lines may leak running to the radiator ....see if they are loose use a line wench ..don't over torque the fitting ..

maybe tough to get at ..on tranny pass side..
j cAT is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Chevrolet > Avalanche | C&K | Silverado | Suburban | Tahoe > Suburban

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:49 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts