Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Dodge > Ram Pickup | Ram SRT10
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools
Old 10-26-2012, 08:28 AM   #1
Stale Trooper
AF Regular
 
Stale Trooper's Avatar
 
Join Date: Mar 2007
Location: Haysville, Kansas
Posts: 126
Thanks: 7
Thanked 5 Times in 5 Posts
'98 Ram 1 Ton All gauges out, odometer mileage flashing

I have a ’98 Dodge Ram 3500 diesel & 5 speed manual transmission, with 160K on it. I had let the truck set for about 2 weeks, then went to start it and it was all but dead. Wouldn’t crank, but did give a beeping sound from the instrument cluster. I found that the battery posts were corroded; I cleaned & tightened them. Charged the battery for a brief period (5-10 minutes @40 Amps), and got the same result as above. I noticed at that time the odometer was flashing the mileage display. (I'm not seeing the "no bus" message).

I have a “Start” setting on my charger (200 Amp) and used that to get the truck started. The truck seems to run fine, and as far as I know, everything is working fine except these: All gauges except Tach are inop, ABS & Brake lights are on, underhood lamp, & dome light are inop, radio possibly inop, odometer is not counting mileage in either the total miles or trip functions.

I read on here in another thread about a troubleshooting test for the instrument cluster, how do I perform that?

I was not having any problems with this vehicle until this incident. Any help will be appreciated!
__________________
Stale Trooper
'05 CVPI
(My '99 got wiped out with 238,513 miles on the clock, stupid woman driver)

It's White, with a black grille, a spotlight, and the butt is black. Need a picture? Thought not
Stale Trooper is offline   Reply With Quote
Old 10-29-2012, 09:03 PM   #2
Chris Stewart
AF - Advisor
 
Chris Stewart's Avatar
 
Join Date: Mar 2004
Location: Nashville, Tennessee
Posts: 2,920
Thanks: 113
Thanked 41 Times in 39 Posts
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

I'd try a good battery charge on both batteries separately with the negative cables disconnected.
After re-connecting the cables, turn the keyswitch On then slowly mash the throttle to the floor then release. Turn the keyswitch Off.
Now start the engine and see if everything reset.
__________________
1992 Bravada, 201K, stock
1997 Bravada, 101K, stock...was "called away"

"Cornbread Red", 2001 Dodge 2500,4X4,HO Cummins Diesel,QC,SWB,6spd.,Banks boost&pyro,US Gage fuel press.,Edge Drag Comp,4"exh.,cowl hood, bhaf, black Holley pump, 140gph...13psi WOT, Vulcan Big Line, kevlar/ceramic single disc clutch, cheapo fuel cooler, 8x.010" vco injector nozzles, Cat turbo 62-65-.70A/R, 497hp 1089 tq 8/25/14

Time to turn so's you don't burn.
Chris Stewart is offline   Reply With Quote
Old 10-30-2012, 04:02 PM   #3
Stale Trooper
AF Regular
Thread starter
 
Stale Trooper's Avatar
 
Join Date: Mar 2007
Location: Haysville, Kansas
Posts: 126
Thanks: 7
Thanked 5 Times in 5 Posts
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

Quote:
Originally Posted by Chris Stewart View Post
I'd try a good battery charge on both batteries separately with the negative cables disconnected.
After re-connecting the cables, turn the keyswitch On then slowly mash the throttle to the floor then release. Turn the keyswitch Off.
Now start the engine and see if everything reset.
Did all of the above; Same result as before, the problem remains...... I forgot to mention, All normal warning & indicator lights seem to be functioning properly .
__________________
Stale Trooper
'05 CVPI
(My '99 got wiped out with 238,513 miles on the clock, stupid woman driver)

It's White, with a black grille, a spotlight, and the butt is black. Need a picture? Thought not
Stale Trooper is offline   Reply With Quote
Old 10-30-2012, 05:24 PM   #4
Chris Stewart
AF - Advisor
 
Chris Stewart's Avatar
 
Join Date: Mar 2004
Location: Nashville, Tennessee
Posts: 2,920
Thanks: 113
Thanked 41 Times in 39 Posts
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

Try this to check your gauges out. Get in, put the key in the ignition, hold the trip reset in, turn the key to the run, not start position and hold until the gauges move. If your gauges are good the cluster will run through a self diagnostic and your odometer will readout any problems.
Thanks Kansascrewcab76!!!
__________________
1992 Bravada, 201K, stock
1997 Bravada, 101K, stock...was "called away"

"Cornbread Red", 2001 Dodge 2500,4X4,HO Cummins Diesel,QC,SWB,6spd.,Banks boost&pyro,US Gage fuel press.,Edge Drag Comp,4"exh.,cowl hood, bhaf, black Holley pump, 140gph...13psi WOT, Vulcan Big Line, kevlar/ceramic single disc clutch, cheapo fuel cooler, 8x.010" vco injector nozzles, Cat turbo 62-65-.70A/R, 497hp 1089 tq 8/25/14

Time to turn so's you don't burn.
Chris Stewart is offline   Reply With Quote
Old 10-30-2012, 10:54 PM   #5
Stale Trooper
AF Regular
Thread starter
 
Stale Trooper's Avatar
 
Join Date: Mar 2007
Location: Haysville, Kansas
Posts: 126
Thanks: 7
Thanked 5 Times in 5 Posts
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

I'll give that a try Wednesday afternoon, have stuff going on early in the day, will try it when I get home. Thanks
__________________
Stale Trooper
'05 CVPI
(My '99 got wiped out with 238,513 miles on the clock, stupid woman driver)

It's White, with a black grille, a spotlight, and the butt is black. Need a picture? Thought not
Stale Trooper is offline   Reply With Quote
Old 10-31-2012, 01:46 PM   #6
Stale Trooper
AF Regular
Thread starter
 
Stale Trooper's Avatar
 
Join Date: Mar 2007
Location: Haysville, Kansas
Posts: 126
Thanks: 7
Thanked 5 Times in 5 Posts
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

Quote:
Originally Posted by Chris Stewart View Post
Try this to check your gauges out. Get in, put the key in the ignition, hold the trip reset in, turn the key to the run, not start position and hold until the gauges move. If your gauges are good the cluster will run through a self diagnostic and your odometer will readout any problems.
Thanks Kansascrewcab76!!!
Chris, I did the procedure you described, and got 3 codes: 920, 921 & 999. I'm assuming "999" signifies the end of the code list. If not, do you know what they all mean?
All of my gauges and lights showed signs of life (they went through a full sweep, then back to "0", the odometer is still flashing my mileage) but still aren't working yet.
__________________
Stale Trooper
'05 CVPI
(My '99 got wiped out with 238,513 miles on the clock, stupid woman driver)

It's White, with a black grille, a spotlight, and the butt is black. Need a picture? Thought not
Stale Trooper is offline   Reply With Quote
Old 10-31-2012, 09:26 PM   #7
Chris Stewart
AF - Advisor
 
Chris Stewart's Avatar
 
Join Date: Mar 2004
Location: Nashville, Tennessee
Posts: 2,920
Thanks: 113
Thanked 41 Times in 39 Posts
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

Sent you a PM.
__________________
1992 Bravada, 201K, stock
1997 Bravada, 101K, stock...was "called away"

"Cornbread Red", 2001 Dodge 2500,4X4,HO Cummins Diesel,QC,SWB,6spd.,Banks boost&pyro,US Gage fuel press.,Edge Drag Comp,4"exh.,cowl hood, bhaf, black Holley pump, 140gph...13psi WOT, Vulcan Big Line, kevlar/ceramic single disc clutch, cheapo fuel cooler, 8x.010" vco injector nozzles, Cat turbo 62-65-.70A/R, 497hp 1089 tq 8/25/14

Time to turn so's you don't burn.
Chris Stewart is offline   Reply With Quote
Old 12-28-2012, 11:27 PM   #8
MIKESHORT
AF Newbie
 
Join Date: Dec 2012
Location: OTTUMWA, Iowa
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

chris i have 98 dodge ram 1500 4x4 with same problem as stale troopercode 920 921 and 999 with no start no gauges did gauge test all worked
MIKESHORT is offline   Reply With Quote
Old 01-01-2013, 09:19 PM   #9
Chris Stewart
AF - Advisor
 
Chris Stewart's Avatar
 
Join Date: Mar 2004
Location: Nashville, Tennessee
Posts: 2,920
Thanks: 113
Thanked 41 Times in 39 Posts
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

__________________
1992 Bravada, 201K, stock
1997 Bravada, 101K, stock...was "called away"

"Cornbread Red", 2001 Dodge 2500,4X4,HO Cummins Diesel,QC,SWB,6spd.,Banks boost&pyro,US Gage fuel press.,Edge Drag Comp,4"exh.,cowl hood, bhaf, black Holley pump, 140gph...13psi WOT, Vulcan Big Line, kevlar/ceramic single disc clutch, cheapo fuel cooler, 8x.010" vco injector nozzles, Cat turbo 62-65-.70A/R, 497hp 1089 tq 8/25/14

Time to turn so's you don't burn.
Chris Stewart is offline   Reply With Quote
The Following User Says Thank You to Chris Stewart For This Useful Post:
Stale Trooper (01-05-2013)
Old 01-05-2013, 11:36 AM   #10
Stale Trooper
AF Regular
Thread starter
 
Stale Trooper's Avatar
 
Join Date: Mar 2007
Location: Haysville, Kansas
Posts: 126
Thanks: 7
Thanked 5 Times in 5 Posts
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

Quote:
Originally Posted by Chris Stewart View Post
I'm going to follow these steps, however, I have not had a "No Bus" indication thus far.

Could a bad dash-to-body, or body-to-frame ground be the "root cause" for this problem? I have noted that if I bypass factory parameters, (IE: the Trip Reset button test) some things change momentarily.

I'm going to check the alternator to make sure it's putting out too. I took the truck out last night, and made it about 7-1/2 miles with the headlights on, where it died a slow and agonizing death from near total electrical failure (batteries died), It took a long time jumper cable charging to get her going again, Headed home, and got within 100 yards of my driveway when it died again. Temp was in the 15* range.

BTW - Batteries are Wally's best 850CCA new in Feb 11. All terminals are clean & tight.
__________________
Stale Trooper
'05 CVPI
(My '99 got wiped out with 238,513 miles on the clock, stupid woman driver)

It's White, with a black grille, a spotlight, and the butt is black. Need a picture? Thought not
Stale Trooper is offline   Reply With Quote
Old 06-21-2016, 06:54 PM   #11
Olic
AF Newbie
 
Join Date: Jun 2016
Location: Phelpston
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

I have this exact same problem, I have a 1998 Dodge ram 3500 with a 5.9 L Cummins diesel five-speed. Only the tack will work and no other gauges will work, also I have no voltage coming from my alternator. Could the lack of voltage from the alternator be triggering these gauges for not working. Have done the tests on the gauge and they all sweep. Seems like cluster is getting power and is working correctly however when running engine no gauges work.
Olic is offline   Reply With Quote
Old 06-22-2016, 05:57 AM   #12
Stale Trooper
AF Regular
Thread starter
 
Stale Trooper's Avatar
 
Join Date: Mar 2007
Location: Haysville, Kansas
Posts: 126
Thanks: 7
Thanked 5 Times in 5 Posts
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

Hey Olic, Welcome to the forums!
I finally solved my problem by replacing the computer on the left (passenger) side on the firewall. I took it to my local Dodge dealer, which sourced a rebuilt computer, programmed it, and it hasn't had a hiccup since. This was almost 3 years ago, and the computer & installation ended up being about 1/3 the cost of a new stock computer.
Hope this helps, Sorry I don't recall the source of the computer, but my dealer knew about it, and saved me a ton of money!
__________________
Stale Trooper
'05 CVPI
(My '99 got wiped out with 238,513 miles on the clock, stupid woman driver)

It's White, with a black grille, a spotlight, and the butt is black. Need a picture? Thought not
Stale Trooper is offline   Reply With Quote
The Following User Says Thank You to Stale Trooper For This Useful Post:
Chris Stewart (06-22-2016)
Old 06-22-2016, 08:43 PM   #13
Olic
AF Newbie
 
Join Date: Jun 2016
Location: Phelpston
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

Ok will try this, thanks for the help. I will keep ya posted
Olic is offline   Reply With Quote
Old 06-27-2016, 07:04 PM   #14
Olic
AF Newbie
 
Join Date: Jun 2016
Location: Phelpston
Posts: 3
Thanks: 0
Thanked 1 Time in 1 Post
Thumbs up Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

Thanks state trooper ... Installed a new PCM and fixed all the problems
Olic is offline   Reply With Quote
The Following User Says Thank You to Olic For This Useful Post:
Chris Stewart (06-28-2016)
Old 06-28-2016, 07:30 PM   #15
Chris Stewart
AF - Advisor
 
Chris Stewart's Avatar
 
Join Date: Mar 2004
Location: Nashville, Tennessee
Posts: 2,920
Thanks: 113
Thanked 41 Times in 39 Posts
Re: '98 Ram 1 Ton All gauges out, odometer mileage flashing

Thanks for the update Olic.
__________________
1992 Bravada, 201K, stock
1997 Bravada, 101K, stock...was "called away"

"Cornbread Red", 2001 Dodge 2500,4X4,HO Cummins Diesel,QC,SWB,6spd.,Banks boost&pyro,US Gage fuel press.,Edge Drag Comp,4"exh.,cowl hood, bhaf, black Holley pump, 140gph...13psi WOT, Vulcan Big Line, kevlar/ceramic single disc clutch, cheapo fuel cooler, 8x.010" vco injector nozzles, Cat turbo 62-65-.70A/R, 497hp 1089 tq 8/25/14

Time to turn so's you don't burn.
Chris Stewart is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Tags
battery , dead , flashing , gauges , odometer
Go Back   Automotive Forums .com Car Chat > Dodge > Ram Pickup | Ram SRT10

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 04:33 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts