Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Venture
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools
Old 01-27-2005, 02:36 PM   #1
GTackett
AF Newbie
 
Join Date: Jan 2005
Location: Bedford, Indiana
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Question Low coolant light and no heat related?

Our 1998 "low coolant" light has been coming off and on for a few months (even though there has always been plenty of coolant in the radiator and the reservoir). In the last week the heat has only been "hot" while controls are in the heat position only intermittently.

There is plenty of air flow. I haven't had a chance to check the temp. of the hoses to the heater core to see if they are hot, my guess is they are because when the heat does come on it comes on instantly and it is very warm.

The thermostat is operating properly as the temp. guage rises steadily and maintains 180 +/- operating temp.

I believe the Air Mix Door Actuator may be the problem, but I wonder if the "low coolant" light may have something to do with this problem.

Doe anyone know if the "low coolant" light and the Air Mix door (possible) problem could be releated?

Thanks,
Greg
GTackett is offline   Reply With Quote
Old 01-28-2005, 03:02 PM   #2
broughy84
AF Enthusiast
 
broughy84's Avatar
 
Join Date: May 2004
Location: Bicknell, Indiana
Posts: 1,135
Thanks: 0
Thanked 2 Times in 1 Post
Re: Low coolant light and no heat related?

has your intake gaskets been changed?

you have air in the cooling system.
__________________
Matthew Brough
1997 Geo Prizm -- 301,000 miles
2000 Honda Accord -- 225,000 miles
2004 GMC Yukon XL -- 223,000 miles

1987 Jeep Comanche -- 116,000 miles


broughy84 is offline   Reply With Quote
Old 01-28-2005, 03:07 PM   #3
GTackett
AF Newbie
Thread starter
 
Join Date: Jan 2005
Location: Bedford, Indiana
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Intake gasket was changed at 35k (just under warranty!!!).

I've read about the air in the coolant issue, which sounds like it may give intermittent problems.

I'm taking it to a GM mechanic this weekend .... we will see.
GTackett is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Chevrolet > Venture

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:56 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts