Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Oldsmobile > Cutlass Series > N-Body General Discussions
N-Body General Discussions N-Body Discussions
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools
Old 08-31-2020, 12:56 AM   #1
cutlassowner94
AF Newbie
 
Join Date: Aug 2020
Location: Richmond, Virginia
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
elecretical

I have a 1994 Olds Cutlass Supreme S 3.1lt and 6 weeks ago I was driving to my sisters house during the morning and it was running fine,but that same day,during the evening, it was driving like it had NO POWER.I through that may gas filter was clogged which I brought one to have someone to install. Found out that I needed a module plugs,but took it to Firestone & said that what I needed was an ingnation coil,module and plugs for $563.69,which they willn't charge me any labor.Is it common for those things to go out? I had one put in about 2018,but I don't think it's the same ones.If it was could person tell if THAT one was changed?I was also told NOT to drive the car,cause he has seen raw fuel get into one of the cyliduars and ruid it,so it's been parked for 6 weeks.All I do now is start it,go forward and backwards without giving any gas. what cauing this and is that price right or could I shop around?
cutlassowner94 is offline   Reply With Quote
Old 08-31-2020, 08:04 AM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,942
Thanks: 25
Thanked 369 Times in 363 Posts
Re: elecretical

Welcome to the forum. Without knowing the service history and a better description of the problem, hard to advise here. I would get a another shop to check it out. Also, make sure you get a written guaranty that this work would correct the condition..
__________________
maxwedge is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > Oldsmobile > Cutlass Series > N-Body General Discussions

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:22 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts