Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Saturn > SC/SL/SW
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools
Old 08-04-2009, 06:45 PM   #1
turtleisland
AF Newbie
 
Join Date: Aug 2009
Location: Haiku, Hawaii
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy 99 Saturn SL Won't Start!

I have a 99 Saturn SL and its got 150,000 or so miles on it. It has been running high rpm between 2 and 3 when I put it into park after driving for a while, so I just shut the car off and Ignored it. Until yesterday morning when I started the car and got halfway out of the driveway and it stalled. The radio still works, beeps still work, all battery powered stuff still working. I tried to start it again and just got a chug chug chug.. engine wouldnt turn over. So I tried again today and am getting the same but sometimes with a slight combustion but the car doesn't start. And I smell gas after trying to start the car maybe because its flooded. Every time I try I get the trying to start chugging noise and a little combustion .. and then the gas smell. I need to change the oil filter on it. I just filled her up with gas the day before and it rained all day and night. I have a sneaking suspision it has something to do with those high rpms after putting it in park though.. and the fact that the transmission has been acting a little faulty, meaning that 3rd gear takes forever to shift up to fourth. It's an automatic. Please help! What is wrong with my car???? Anyone? Aloha Thank you for your time!
turtleisland is offline   Reply With Quote
Old 08-04-2009, 07:40 PM   #2
RC1488
AF Enthusiast
 
Join Date: Jan 2008
Location: carmel, New York
Posts: 982
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 99 Saturn SL Won't Start!

This is what happens when you let the little things go!!

Your ECTS is bad. It cracked a while ago and now most likely cracked even worse possible ruining the connector. New one can be bought from Autozone for 10 bucks. Install it. Then hold the pedal down at Wide open throttle. This shuts off the injectors so that excess fuel will be burned. Eventually it will start up. OR you can remove the spark plugs, crank the engine over a little, then reinsert the plugs. It also should start right up after that.

The ECTS is VITAL to many subsystems of the car; Idle rpms, fuel ratios, tranny shift points, Torque converter lock up points, fan control, ..etc etc. When it cracks it tells the PCM the engine is cold thus the PCM make the mixture extremely rich, raises rpms, and will not allow the car to shift so that high rpms are sustained inorder to warm the engine up faster so that on board emissions tests can be completed and passed.

If the connector has antifreeze on it or is corroded it must be replaced. Although the sensor is 10 bucks, this connector is 30 from the dealer. An Intake Air Temperature sensor connector will also work. Junkyard is the best to find replacements for the ECTS connector though.

I have posted a how-to video for this in older threads. The search button is your friend
__________________
Present: '02 Sl1 Man '01 SC1 Man '97 Sl2 Auto '96 SL2 Auto '95 SC2 Man
Past: '99 Sl2 Auto '97 Sl2 Man '98 SL2 Man '95 Sl2 Man '95 Sl2 Man '94 Sl2 man
RC1488 is offline   Reply With Quote
Old 08-05-2009, 05:54 PM   #3
turtleisland
AF Newbie
Thread starter
 
Join Date: Aug 2009
Location: Haiku, Hawaii
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 99 Saturn SL Won't Start!

Thank you for your reply! I'm sure that this is probably correct. But, I just tried to start my car again and noticed that gas is leaking on the ground, beneath the drivers side door. So, I guess theres a leak in the fuel line now! Probably pressure built up and maybe the fuel filter is clogged? I'll replace the E.. thing you said. Much mahalos friend! Aloha
turtleisland is offline   Reply With Quote
Old 08-11-2009, 10:43 PM   #4
amanda60302
AF Newbie
 
Join Date: Aug 2009
Location: unionville, Virginia
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 99 Saturn SL Won't Start!

Hi did you ever figure out if this is the issue? Just curious as I have a 99 sl1 that was doing the same high rpm thing in park and will not start now but our issues concern the alarm and factory keyless entry system...Just thought I would ask how this worked out for future refrence lol...

=0) Hope it went well!
amanda60302 is offline   Reply With Quote
Old 08-13-2009, 09:47 PM   #5
turtleisland
AF Newbie
Thread starter
 
Join Date: Aug 2009
Location: Haiku, Hawaii
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 99 Saturn SL Won't Start!

Yes I did resolve the issue. Well, at least the not starting part. It was a busted fuel line. Easy fix! I've dealt with keyless entry systems in my buick before, can be a little complicated on the newer cars. But its usually all just based resistance readings. Good luck with that! The advice given to me on an earlier reply if you scroll up, about the ECM... whatever it is called... I researched it a little and it looks like that might be a solution to the high rpm.. i think one of my PCV device readings is off too. sorry, i dont know if that was much help. if i find out more. I'll let you know. ALOHA! peace
turtleisland is offline   Reply With Quote
Old 08-13-2009, 09:52 PM   #6
amanda60302
AF Newbie
 
Join Date: Aug 2009
Location: unionville, Virginia
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 99 Saturn SL Won't Start!

Thanks, Still have no clue what the issue is, I am about ready to give up! I hate to loose my car it really has been a trooper! I just dont know what else to do at this point and dont have alot of money to put into trying to fix it if I cant even figure out what to fix lol...Thanks again for your answer!
amanda60302 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Tags
'99 , saturn , sl1 , start , won't
Go Back   Automotive Forums .com Car Chat > Saturn > SC/SL/SW

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 09:11 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts