Our Community is 940,000 Strong. Join Us.


No power coming out of the hole


Goza
01-21-2010, 06:39 PM
92 3000GT. No power or acceleration taking off from a dead stop. I have to ease my way up to about 35 before itll take off.
New fuel and air filter , plugs wires( even those 3 pain in the ass ones in the back) all that, new timing belt.
I did have a fuel pump relay problem before. Replaced the relay and it seemed to have had the balls I thought it should have , then for some unknown reason, it went back to its sluggish self.
I also have an electrical problem that may or may not be related, but my interior lights do not work, and I have no idea why.
Grounding problem maybe?
Any ideas?

VR43000GT
01-21-2010, 06:45 PM
Is this an automatic transmission? If it is, it could be in safe mode which keeps it in a higher gear regardless of speed when something has broken inside the transmission making it quite slow from a stop.

Goza
01-21-2010, 07:02 PM
5 speed standard.

VR43000GT
01-21-2010, 07:05 PM
I would definitely look at the relay again as I would be willing to bet that is your problem. Or, if you want to, you could just hardwire it.

Goza
01-21-2010, 07:11 PM
Could that mess the fuel pump up being on all the time? By passing the relay I mean.

VR43000GT
01-21-2010, 07:23 PM
Not really. There are TONS of people who do it with their 3S. Most people do it for more performance out of their fuel system though you could do it in your case as well. It has been done reliably many times.

Goza
01-21-2010, 07:29 PM
Well since I have come to find out the relay that was used on my car was found to be a piece of crap ( apparently by Mitsubishi) and was only supposedly used for only a short time, and was extremely had to find,Ill have to look into that option. Thanks!

VR43000GT
01-22-2010, 12:08 AM
check the chart.. http://www.carchart.webs.com (http://www.carchart.webs.com/)

Wow. Spam much? I'm guessing we won't be seeing a lot more of you.

Add your comment to this topic!