Our Community is 940,000 Strong. Join Us.


post boost leak test


chickmagnet
11-08-2009, 07:32 PM
so i did the leak test yesterday and i have a leak behind the timing belt covers (under the right side cam gears). i really dont have the time to jack up the motor and pull the motor mount to get to where the leak is (and fix it). im thinking a gasket of some sort on a pulley. i was thinking head gasket at first, but i wasnt spitting any oil (that i could tell) and i didnt have any anti-freeze in my oil when i did oil change today...has anyone else experienced this or have a better educated guess on what it could be? thanks

Stealthee
11-09-2009, 12:08 PM
Theres no way its coming from under the timing covers.

chickmagnet
11-09-2009, 03:42 PM
ok, not as high as the timing covers but it is leaking out from the crankcase somewhere. theres the 2 timing covers on top and then theres one cover underneath those and the leak is coming from behind there. but i cant pull that bottom cover off to see where its leaking unless i jack up the motor. ill try to post a video of it friday afternoon.

chickmagnet
11-09-2009, 08:59 PM
i was looking at pics from the JRC 60K tuneup site and the leak is near the idler pulley...any thoughts?

chickmagnet
11-21-2009, 12:29 PM
i lied, i found the leak...its the crank case seal :shakehead. sooo, im wondering A) could my pcv valve not be working right, B) did i do something wrong on the boost leak test?, or C) WTF IS WRONG WITH MY CAR!!! lol.

on the leak test, the only thing i did was unhook the air-cleaner and pressurized the system from there...is this right? am i not blocking something off that i should be?

please help!!! thank you :)

Add your comment to this topic!