Our Community is 940,000 Strong. Join Us.


Car is Possessed


AngelClawz
12-15-2007, 06:50 PM
I just bought tha 99 Mercury Mystique 2 weeks ago. Used car. So far.. engine light came on. Had diagnostic ran. Replaced spark plugs for cylinders, replaced ignition wires, replaced MAF. Today the car battery died. No lights were left on, the battery is only 6 months old. No signs that it was going to give out. Finally got it jumped started and it was doing 30mph 3k rpms on idle..nobody in the car..gas not being pushed. It has dont this before, but not since the MAF so I assumed the "wanting to take off" was part of the MAF. Any suggestions? Whats wrong with this car??

AngelClawz
12-16-2007, 07:06 PM
I jumped it again today. Started to drive it to Autozone for a battery, the engine light came on. Had battery tested, battery was bad. Diagnostic came up with mis-fires. So I assume coils because the plugs and wires were just changed. When I restarted my car engine light didn't come on? Any ideas?

beyondloadedSE
12-16-2007, 07:41 PM
When I restarted my car engine light didn't come on? Any ideas?

Generally that means everything is fine or they cleared your codes.

As for the throttle hang. Thats discussed on the contour forums in the Frequently Asked Questions.

http://contour.org/FAQ/FAQ.php?s=probs&displayid=7

AngelClawz
12-18-2007, 07:15 AM
The engine light came back on again yesterday on my way back to work. I'm sure its the cylinders misfiring and I was assured I could drive it without anything bad happening. So crossing my fingers on that one! It is now reving from 1k rpms to 2k rpms when I am stopped or idleing , it shakes and rocks back and forth when it does this. No clue..maybe the car is just upsets and is trying to comfort it's self! :screwy:

beyondloadedSE
12-18-2007, 09:56 AM
The engine light came back on again yesterday on my way back to work. I'm sure its the cylinders misfiring and I was assured I could drive it without anything bad happening. So crossing my fingers on that one! It is now reving from 1k rpms to 2k rpms when I am stopped or idleing , it shakes and rocks back and forth when it does this. No clue..maybe the car is just upsets and is trying to comfort it's self! :screwy:

Is the CEL flashing? That indicates a misfire.

I would get the code(s) pulled and see exactly whats up.

AngelClawz
01-06-2008, 10:35 AM
I took the car in to the mechanics a almost 2 weeks ago. They found the rear O2 sensor was hanging off of the car and dragging on the concrete. They replaced it, and all was fine and smooth and normal.

For 2 days!

Then it started to stall when in idle, which I just dealt with, and defrosted the car by giving it gas. It would not stall after it was driven. The shaking and rocking started back up again, but only when stopped at a light. I drove it to work one day. When I left work the breaks decided not to work. Scary!! I was able to get the car home by slipping into nuetral at red lights.

I took it back to the mechanics, by the time I got there the engine was smoking. They pulled up tons and tons of codes. The mass air flow, which I already replaced, mis-fires in the cylinders, and fuel running lean.

They replaced the idle air flow sensor. They credited the breaks to the idle air flow sensor which was making the engine shut down, making the vac not have enough to come to a complete stop. They checked the fuel injectors and so forth, all was good and clean. The temp guage never read hot, but they looked at it and it was running hot, but the water wasn't? They said I needed to replace the main computer?

Engine light came off, the car drove normal for a day, light came back on, now its back to stalling in idle, and shaking. My question is..does anyone know if all these issues can be attributed to the main computer?

AngelClawz
01-14-2008, 03:41 PM
Car started rocking, vibrating, stalling, smoking. Fixed the car!!! All it needed was to be traded in for a new car!! Go figure! :)

Add your comment to this topic!