Our Community is 940,000 Strong. Join Us.


trofeo sauna


mich123
07-04-2007, 02:06 PM
I have a 92 trofeo, and I'll start the car then everything on thse panel goes blank except the tach. The defrost turns on automaticly and blows hot air. What can be done about this.

maxwedge
07-04-2007, 02:52 PM
Welcome to AF. What panel, dash, heater control?

mich123
07-04-2007, 07:40 PM
it's the instrument cluster, which is the digital odometer and the information center

maxwedge
07-05-2007, 05:27 AM
It is more than likely failing.

mich123
07-05-2007, 08:12 AM
yes I agree. But why? Any suggestions? I would like to fix it myself if possible

maxwedge
07-05-2007, 04:17 PM
Can you overhaul a digital dash, take it out and apart , look for bad soldered connections, if you feel up to this, if not exchanges are available. Also check for proper grounds in the dash circuitry.

DigitizedWarmth
07-29-2007, 12:05 AM
You're right. It IS the instrument cluster, and more specifically, a corrupt capacitor. The good news: cost a few cents to replace. The bad news: it is quite technical.

Here's a link that will tell you everything you need to know to fix it.

http://webspace.netmatters.co.uk/causeway/gen_iv/ipc_fix.htm

mich123
07-29-2007, 08:26 AM
Thanks for the advice. I'm going to tackle it A.S.A.P the extra's about static control will be helpful. I'll let you know the outcome.

mich123
10-09-2007, 12:18 PM
Hi there, the link you set up is not working can you help me to locate it? thx

mich123
10-09-2007, 12:21 PM
could some one help me to find the instructions on how to replace the corroded circute in the cluster panel. the link does not go throgh. thx

Add your comment to this topic!