Our Community is 940,000 Strong. Join Us.


engine problems.


ylberi
08-12-2005, 07:29 PM
hello everybody. I am Ylber and I am from Kosova. very small country in Europe. I own a 1990 Mitsubishi colt GLX i, in a very good shape, only 94000 km .Maybe the story will be long but i want to give all the details. one year ago i was driving in my car and i went to a shop. i turned off the engine, went to the shop and came back after only 1 minute. when I tried to turn the engine on it didnt start. After 6 months of troubles I was able to fix it and the problem according to the service man was with the ECU and the distributor. the car was working very good. just after two weeks other problems started. the check engine light went on and the engine is not working properly. black smoke comes from the exaust. it is just like the fuel doesnt flow good and the engine shakes so much that sometimes i think the entire vehicle will go apart. just today i checked the oil and the level was about 5 milimetres above the maximum level. i changed the oil and i changed two spark plugs. the vehicle worked properly for 5-10 minutes and then again i had the same problem. When the distributor was replaced it was not exactly the exact same distributor; it did not have the same numbers printed on it but it was the same type-electronic. so please guys if you have any idea tell me because i have spent a fortune on that car and i dont want to hate it because i love that car too much; it saved my life twice.

ylberi
08-13-2005, 07:22 AM
hello everybody. I am Ylber and I am from Kosova. very small country in Europe. I own a 1990 Mitsubishi colt GLX i, in a very good shape, only 94000 km .Maybe the story will be long but i want to give all the details. one year ago i was driving in my car and i went to a shop. i turned off the engine, went to the shop and came back after only 1 minute. when I tried to turn the engine on it didnt start. After 6 months of troubles I was able to fix it and the problem according to the service man was with the ECU and the distributor. the car was working very good. just after two weeks other problems started. the check engine light went on and the engine is not working properly. black smoke comes from the exaust. it is just like the fuel doesnt flow good and the engine shakes so much that sometimes i think the entire vehicle will go apart. just today i checked the oil and the level was about 5 milimetres above the maximum level. i changed the oil and i changed two spark plugs. the vehicle worked properly for 5-10 minutes and then again i had the same problem. When the distributor was replaced it was not exactly the exact same distributor; it did not have the same numbers printed on it but it was the same type-electronic. so please guys if you have any idea tell me because i have spent a fortune on that car and i dont want to hate it because i love that car too much; it saved my life twice.
guys. I checked the oil today and it was about 5 milimeters above the maximum level. I think the fuel is getting mixed with oil. Does anyone of you think that this might be causing the engine to shake.

ColtOwner666
11-13-2005, 01:30 PM
maybe a broken motormount? check them... and it sounds like your engine isn't burning the fuel proberly.

Add your comment to this topic!