Xantia electric front windows


peter_dunkley
07-14-2005, 03:58 PM
Hello,

I have a 1997 1.9TD SX Xantia. Both front windows stopped working today. None of the three switches (one for the drivers window and two for the passenger window) appear to have any effect. The rear windows do work.

I have checked both the fuses (F29 for the windows and F30 for the switches) they are both fine. Both of the fuse connectors have power supplied to them.

The window switches do not appear to have any power supplied to them, applying power directly to a switch allows me to operate a window. I cannot hear a relay click when I activate the switch (either with or without power).

Has anybody seen this before?

I suspect the relay but I cannot check this because my Haynes manual does not identify the individual relays. I would still be a little confused if it was the relay because the Haynes circuit diagram indicates that the same relay is used for all four windows (and the rear windows do work).

Thanks,

Peter

tottsy
07-21-2006, 11:23 AM
Hello,

I have a 1997 1.9TD SX Xantia. Both front windows stopped working today. None of the three switches (one for the drivers window and two for the passenger window) appear to have any effect. The rear windows do work.

I have checked both the fuses (F29 for the windows and F30 for the switches) they are both fine. Both of the fuse connectors have power supplied to them.

The window switches do not appear to have any power supplied to them, applying power directly to a switch allows me to operate a window. I cannot hear a relay click when I activate the switch (either with or without power).

Has anybody seen this before?

I suspect the relay but I cannot check this because my Haynes manual does not identify the individual relays. I would still be a little confused if it was the relay because the Haynes circuit diagram indicates that the same relay is used for all four windows (and the rear windows do work).

Thanks,

Peter
Hi Peter

Have you managed to sort your problem. Interested as i have a Xantia 1.9TD 1997 and none of the windows are working. Have replaced the control unit and fuses but not sure about the relays how many there should be and where they are?

Thanks a lot

Sharon

flissfloss
08-05-2006, 01:43 PM
Hello Peter,I am having exactly the same problem with my xantia.If you managed to resolve it,then i would appreciate any help that you can give.regards steve

betuaintgotthis
11-16-2010, 02:29 PM
I suspect your fault is in the wiring loom between the door and body. The constant opening and closing can weaken the wires untill they break. It is fiddely but you can simply just rejoin the wires.

Add your comment to this topic!