Our Community is 940,000 Strong. Join Us.


prob TRC


jz-x
12-12-2004, 06:24 AM
http://www.automotiveforums.com/vbulletin/showthread.php?t=330748

pls chk this link

nitrous36
12-14-2004, 06:33 PM
No one here can probaly help you because MarkIIs and Chasrers are rare outside of Japan. There could be a shortage in the wires of the TC switch. If the TC switch can be popped off the dash then look behind it to see if the wires are connected.

jz-x
12-14-2004, 10:32 PM
I didn't cheack but am quiet sure they are connceted.......see when you push the button on the tracation works but when you switch it off there should be no tracation at all but i can fell the traction still there....I did cheack with other owners of markII and chasers here the some think they have.

nitrous36
12-15-2004, 05:48 PM
Your lucky to have a Toyota MarkII. That is one of the cars I want that we dont and cant get here in the U.S. I want a 92-95 MarkII Tourer V. They are so nice. I want one in dark green M.I.O.

jz-x
12-15-2004, 11:49 PM
why they dont allow it in U.S......there are many here......mine is dark green sometime I fell it's black....i want to get the full power in my wheels but if i will have this problem I wont be happy....anyway i'll take it to some grages here and see what they say (i hope they will help).i'll try to post my markII pics.

nitrous36
12-16-2004, 08:06 PM
I was going to ask you to post some pics. Have you done anything to the car yet?

rivalbro
03-21-2005, 05:51 AM
trc works on my mark II, i can also turn it off from the switch and then it doesnt work but then the drivin gets tricky, th ecar drifts due to enormous power sometimes.

jz-x
03-22-2005, 12:52 PM
i have that switch too,But when you turn it off ya the ride gets real cool but you still fell there is like something holding the rear wheels.

rivalbro
03-22-2005, 02:10 PM
did you get the wheel alignment checked? sometimes it can cause hell and you don't even know what's wrong.

jz-x
03-28-2005, 11:47 AM
i checked that the first day i brought the car here.........the car is all OK ,i have noticed this in couple of marks here same thing it takes time to know that.

rivalbro
03-28-2005, 01:30 PM
Did you try taking it to the Toyota service center? Mark II is a little similar to 1993 LS 400, or 300, maybe they can check it out, just try.

Add your comment to this topic!