Our Community is 940,000 Strong. Join Us.


1995-2003 S10 & Blazer Front End Clunk Pop Fix!!! Read!!


Pages : 1 2 [3] 4

metallica21156
08-10-2005, 05:18 PM
which bushing did you replace? the one that hooks up to the stud on the frame? i don't know it theres one where the torsion bar connect with the cross member. from looking at it could you tell it was hitting? would yours clunk when you started it?

BlazerLT
08-11-2005, 12:09 AM
http://www.sytyarchives.com/howto/viewarticle.php?article_name=torsion_bar_mounts.ph p&dir=suspension

Harryn
08-22-2005, 09:36 AM
A special thanks to BlazerLT for all the info.

I too have had a very frustrating time trying to fix that.
I allways thought that it was something loose and bouncing in the engine compartment. After going over that several times and a couple of wheel alignments I started at the a bunch of other things see the list below.

Here is what I did.
*Upper and lower ball joints (all four)
*Sway bar end links
*all four shocks
*upper and lower control arm bushings

When reading the post about the simple little cheap easy fix, I was very skeptical, but what could it hurt. Well it worked.

I like my truck just a little more now!

BlazerLT
08-22-2005, 09:48 AM
Yea, I know your feeling.

I was SOOOO happy when I found it.

I yelled WOOHOO! when I was driving it when I found it was fixed. The other driver's though I was ready for the nuthouse.

bradhaight
08-29-2005, 07:58 PM
Hey BazerLT - thanks for the clunk post.. It worked on mine, too.. Thanks for saving me the time in replacing the shocks and etc..

The rattle is gone!!! yeh!!

BlazerLT
08-29-2005, 10:33 PM
sahweet!

mbowrsax06
10-10-2005, 12:22 PM
just got a set pt #12383460 $3.45/piece
gonna find out if this does it!!!

denisew
10-13-2005, 12:06 PM
can anyone tell me where i can see the video? when i click on the link
http://www.tweaknews.net/decarbon/clunkfix.AVI, it says "no results for this search, go to home page". I just went and picked up my washers, want to make sure i do it right.

blazee
10-13-2005, 12:40 PM
can anyone tell me where i can see the video? when i click on the link
http://www.tweaknews.net/decarbon/clunkfix.AVI, it says "no results for this search, go to home page". I just went and picked up my washers, want to make sure i do it right.
Check your private messages:
http://www.automotiveforums.com/vbulletin/private.php?

BlazerLT
10-14-2005, 11:05 PM
movies and picture back online for EVERYONE!

Even you Blazee......... ;) :lol:

blazee
10-15-2005, 07:47 AM
Good, now I don't have to email it anymore.

BlazerLT
10-15-2005, 09:03 AM
Good, now I don't have to email it anymore.

Ahhh. That was nice of you.

rental blazer
10-17-2005, 05:20 PM
Just got mine...I'll let everyone know when they are installed....
last week i traded my 85 s-jimmy for a 95 s-blazer sport 2 door with 30 inch mud tires all this time i tuogth that noise that only happens when i am at low speeds 2-3 mph while turning was the sway bar plus the annoying rattle i think from the spare tire carrier oh and i thougth it was odd since it only has 106k miles

nex1
10-22-2005, 01:51 AM
http://www.tweaknews.net/decarbon/clunkfix.AVI stoped working again....

BlazerLT
10-22-2005, 02:46 AM
http://www.tweaknews.net/decarbon/clunkfix.AVI stoped working again....

Click the link in the posting starting this thread.

dsluppic
10-26-2005, 09:14 AM
I am so glad someone has finally found out what the noise is all about! I have owned a 2000 that had this problem from day one of purchase. The dealership said it was the collapsable steering column and replaced that the first 60 days of ownership. I took it back constantly to tell them the noise was still there and after 3 years I turned the vehicle in on a new 2003. No porblems with that one. But we bought a used 2001 GMC Jimmy, the Blazer's sister, and it has the same noise. New shocks back and forth to the shop and still no one can figure it out.

I am a little confused by the post though. What is the two dollar part? The video doesn't show picture and the link for the service bulletin doesn't come up. Do you take out the old hinges and replace them or what? Where do you get the part?

BlazerLT
10-26-2005, 09:53 AM
I am so glad someone has finally found out what the noise is all about! I have owned a 2000 that had this problem from day one of purchase. The dealership said it was the collapsable steering column and replaced that the first 60 days of ownership. I took it back constantly to tell them the noise was still there and after 3 years I turned the vehicle in on a new 2003. No porblems with that one. But we bought a used 2001 GMC Jimmy, the Blazer's sister, and it has the same noise. New shocks back and forth to the shop and still no one can figure it out.

I am a little confused by the post though. What is the two dollar part? The video doesn't show picture and the link for the service bulletin doesn't come up. Do you take out the old hinges and replace them or what? Where do you get the part?

Watch the videos, I show you what to do.

And also the link has been fixed in the first post.

mike cherry
10-27-2005, 06:21 PM
Im so glad that someone finally found the problem. iv read so many threads about that "CLUNK" and what to do, so im going to fix mine ASAP! thanks, and yes im a newbie who has only been reading threads and not posting anything. but i will from now on

BlazerLT
10-27-2005, 07:58 PM
Glad this has helped you. ;)

dsluppic
10-28-2005, 05:54 AM
thanks for getting the link fixed, but I still can't view the video. I can hear the voice but not see the picture. I tried 3 different computers so it isn't the settings on the computers. It must be something in the video. Can you fix it so we can see the video?

BlazerLT
10-28-2005, 11:04 AM
Are you clicking the link in the first post in this thread?

dsluppic
10-28-2005, 12:49 PM
Yes I am. Is there a different link? As I said I can hear it but can not see the video.

dsluppic
10-28-2005, 12:57 PM
i also went to page 2 for the links and the one from tweak news says the page can not be found.

BlazerLT
10-28-2005, 12:58 PM
i also went to page 2 for the links and the one from tweak news says the page can not be found.

You will need the divx codec installed to view the movie as stated previously in this thread.

dsluppic
10-31-2005, 11:02 AM
Thank you so much for all your info. Got the washers from the dealer the other day and my husband had them installed in no time. The noise is gone!

tjurczyk
11-04-2005, 11:20 AM
Okay, well, you've maybe given me some hope on my '94 S-10 Blazer. It has a front end passenger side clunk, but only when you make a left turn. The guy I bought it from replaced the ball joints, cv joints, and a whole host of other things, but never fixed it. I had one person tell me it could be an A-frame bushing causing it... But, could it be this instead? Thought I'd ask before I spent $500 getting the a-frame bushing replaced.

metallica21156
11-04-2005, 09:36 PM
i changed my upper control arm bushings with no luck also. what ever it is its getting worse. i'm going to wait for it to either fall out or brake. nobody can find out where its coming from.

BlazerLT
11-06-2005, 07:33 PM
Okay, well, you've maybe given me some hope on my '94 S-10 Blazer. It has a front end passenger side clunk, but only when you make a left turn. The guy I bought it from replaced the ball joints, cv joints, and a whole host of other things, but never fixed it. I had one person tell me it could be an A-frame bushing causing it... But, could it be this instead? Thought I'd ask before I spent $500 getting the a-frame bushing replaced.

Replace your torsion bar mounts.

BlazerLT
09-06-2006, 02:09 AM
Links have been updated, if you want to view the movie, it is in the first post.

frankjc
11-27-2006, 09:29 PM
Hi. I just found this thread, and it sounds similar to what I have going on.
I have this "clunk" somewhere on my drivers side front. I had originally thought it was the ball joints, because when I went for an inspection sticker, the guy said I needed a l/f lower ball joint, and an idler arm, both of which I replaced right away. When he said that, I thought that would be where the noise is coming from. He said other than those 2 things, my front end was fine. When I realized I still had the noise, I thought maybe the ball joint was defective....nope. Maybe it was loose....nope. I am going to check the hood hinges soon, hopefully that will be the cure. I couldn't get that video clip to work. And the link for the TSB didn't work either.

BlazerLT
11-28-2006, 03:42 AM
The video worls.

Install the divx codec and wait for it to load, it takes time.

mike_flemming
01-28-2007, 04:50 PM
the video doesent work...can someone explain in detail how to do this?

mike_flemming
01-28-2007, 05:00 PM
ok i saw the video...what should i ask for when i go to the dealership? i dont want to look like a fool...

BlazerLT
01-29-2007, 07:33 AM
There is the part number listed in this thread.

I suggest reading through this thread, all the info needed is there.

GregMillar
02-20-2007, 12:36 AM
Guys,

I thought I found that the sway bar bushings were causing my front end passenger clunk and popping but guess what, they weren't.

Before I drop the bomb and show what I learned through scouring the internet, I have replaced the following:

Lower Ball Joints
Passenger Upper Ball Joint
Sway Bar End Links (Had to be replaced Anyways)
Sway Bar Bushings
Front and Rear Shocks

Total bill: ~US$600

After all of that, it wasn't even the problem. There is a service bulletin that talk about this in this upcoming video.

Want to know what the clunk is? Here you go!

http://img1.putfile.com/thumb/9/24723565582.jpg (http://www.putfile.com/pic.php?img=3329776)

Remove this 7mm screw holding the small outer cowl inserts over the hinges. Close the hood.

Remove the covers carefully and don't break the clips.

The hingles will be attached and they are a 13mm nut and bolt.

http://media.putfile.com/clunkfix <---Video Here

That's right, a $2 dollar part fixes this problem that has pissed so many Blazer owners off.

This is the service bulletin that came out in 2001 I believe. Covers all S10 and Blazers.

http://www.zr2.com/frequently_asked_questions/problems/clunking.html

Scroll Down to Rattle.

There you have it, I temporarily laid a couple bunched up shop towels under the flat part in the video and went for a drive on the roughest washboard road within 50 miles and never heard a thing.

Hope you don't go through what I went through.
HELP!

I Think I have the same problem with the stange rattle on my 1995 Blazer
I have replaced the shocks even the windshield.

The Video link and the info link in the post above no longer work and i an not sure how to proceed.

GregMillar
02-20-2007, 03:37 PM
THANKS!!!

I bought the washers today and installed them on both hing mounts
and that took care of the noise that has been driving me nuts for 4 years.
Yes, my Blazer is old but only has 80K miles on it and I plan on keeping it until it dies.

Thank you very much for your help!

Greg

BlazerLT
02-21-2007, 09:56 AM
THANKS!!!

I bought the washers today and installed them on both hing mounts
and that took care of the noise that has been driving me nuts for 4 years.
Yes, my Blazer is old but only has 80K miles on it and I plan on keeping it until it dies.

Thank you very much for your help!

Greg

Glad this helped you. I too was getting driven nutz by the sound. When this fixed it I was on Cloud 9. Felt like a new truck.

edb61
03-30-2007, 12:29 PM
Hi,

For the last 6 months every time I hit a bump in the road, it sounded like the front end of my 2000 Blazer was going to fall off. I came across this thread today and checked my truck at lunch. The driver side hinge was a little loose, I tightened it up and no more clunk. I picked up the washers at the local dealer (2 for $7) and will install them tonight. Again, thanks for the great tip.

Ed B.

nascarfrk
04-02-2007, 03:07 AM
Hi,

For the last 6 months every time I hit a bump in the road, it sounded like the front end of my 2000 Blazer was going to fall off. I came across this thread today and checked my truck at lunch. The driver side hinge was a little loose, I tightened it up and no more clunk. I picked up the washers at the local dealer (2 for $7) and will install them tonight. Again, thanks for the great tip.

Ed B.I too have been chasing this noise on my 97 Blazer. My dad mentioned this forum to me and I suppose I'll check my hood hinge bolts too. I'll let you know what I find.

1996GMCJimmy
05-04-2007, 08:59 AM
Hey guys, thanks a lot for posting this. I cant believe tha clunking noise is finnaly gone! I had wondered for years what it was and alwats thought it was coming from inside the glove compartment, but i did exactly what BlazerLT suggested and it worked.

Also, posting the actual part number made it easier to find the right kind of washer.

usmailman956
06-27-2007, 08:46 PM
I can't get video to work and the small picture in the post really doesn't help, cam you send me a picture a little bigger or more instructions

BlazerLT
06-27-2007, 11:27 PM
I can't get video to work and the small picture in the post really doesn't help, cam you send me a picture a little bigger or more instructions

The videos do work. Both of the links to the video works on the first page.

Please read the whole thread before you ask a lazy question that has already been answered.

usmailman956
06-28-2007, 05:47 PM
Does any one have a copy of this video for blazer clunkfix? I cannot get it to work having trouble with downloading codec

BlazerLT
06-28-2007, 08:32 PM
As it has been said over 10 times in this thread, it says to install the divx codec to get the movie going.

Please read the WHOLE THREAD.

snoboy
07-11-2007, 03:10 PM
BlazerLT thanks a bunch for showing us this fix. I ordered the washers last week from the dealer and installed them today. I test drove the truck and drove on some choppy stretches of road to double check the washer fix worked! My wife's 2001 Blazer no longer needs an entire front end rebuild. Man you saved my bacon. Thanks again.

snoboy

BlazerLT
07-11-2007, 03:13 PM
BlazerLT thanks a bunch for showing us this fix. I ordered the washers last week from the dealer and installed them today. I test drove the truck and drove on some choppy stretches of road to double check the washer fix worked! My wife's 2001 Blazer no longer needs an entire front end rebuild. Man you saved my bacon. Thanks again.

snoboy

Glad to have helped you.

mavrim
09-06-2007, 02:03 PM
Bravo!

I have had this clunk in my 2000 Blazer ZR2 since it was new. I always felt it was a hinge problem, but never took the time to solve it. I was even thinking it could be something loose under the drivers side dash panel. I will be doing this repair soon!

BeachBlazer
01-16-2008, 09:43 AM
There is the part number listed in this thread.

I suggest reading through this thread, all the info needed is there.

Before I get Flamed....I read the thread (tried dead old links and all :banghead: ) but I can not find the part number for the washer......anyone mind helping?

Thanks all!

BeachBlazer
01-16-2008, 09:50 AM
Before I get Flamed....I read the thread (tried dead old links and all :banghead: ) but I can not find the part number for the washer......anyone mind helping?

Thanks all!

Never mind:rolleyes: ....third time looking....many questions with flaming remarks made me miss it....I found it this time:smokin:

turbotwo1
02-25-2008, 07:06 PM
Bumping an old thread but I just wanted to say thanks. I was about to start ordering parts to try and fix the thumping. But i found this thread, went to the dealer and no more thumps. Now i just have to figure out why its running rough, and I fear that its the spider assembly :(

BlazerLT
02-25-2008, 08:48 PM
Bumping an old thread but I just wanted to say thanks. I was about to start ordering parts to try and fix the thumping. But i found this thread, went to the dealer and no more thumps. Now i just have to figure out why its running rough, and I fear that its the spider assembly :(

You are welcome.

If the check engine light is on and the engine won't idle, but will run ok on the road, you have to clean your egr valve which is right under where the plastic intake attaches to the engine.

It will fix the issue.

turbotwo1
02-25-2008, 09:45 PM
No check engine light. It just seems to run rough at idle and it seems to be getting crappy gas milage. I just found out through more research that I might be able to get away with just replaceing the valve instead of the whole spider.

rnisley
03-07-2008, 07:18 PM
Will replacing the solinoid for the automatic transmission, be a cure for the transmission not shifting?

BlazerLT
03-08-2008, 09:59 AM
No check engine light. It just seems to run rough at idle and it seems to be getting crappy gas milage. I just found out through more research that I might be able to get away with just replaceing the valve instead of the whole spider.

Yea, the regulator will need to be replaced.

just remember that the longer you drive it like this, the more damge the gas in the oil will do to your engine. I would still remove and clean the egr as well while you have the upper plenum off and replace the EGR gasket.

BlazerLT
03-08-2008, 09:59 AM
Will replacing the solinoid for the automatic transmission, be a cure for the transmission not shifting?

Please start your own thread on this.

BlazerLT
03-13-2008, 06:06 PM
Here is the video uploaded to google.

<object width="425" height="355"><param name="movie" value="http://www.youtube.com/v/97PUO-BDM0o&hl=en"></param><param name="wmode" value="transparent"></param><embed src="http://www.youtube.com/v/97PUO-BDM0o&hl=en"; type="application/x-shockwave-flash" wmode="transparent" width="425" height="355"></embed></object>

BlazerLT
03-13-2008, 06:07 PM
Weird, here is the link to the video:

http://www.youtube.com/watch?v=97PUO-BDM0o

ZL1power69
03-13-2008, 07:01 PM
LT, is that part still availible at dealers? i'll have to test my truck to see if i have that dreaded rattle.

BlazerLT
03-13-2008, 07:02 PM
LT, is that part still availible at dealers? i'll have to test my truck to see if i have that dreaded rattle.

I can't see why not.

ZL1power69
03-13-2008, 07:10 PM
I can't see why not.
damn it i was just at the dealer today too, forgot to ask them about it :banghead:

Add your comment to this topic!