Our Community is 940,000 Strong. Join Us.


2000 blazer 2 dr 4x4, loud humming noise and grinding noise


MrEd002u
04-25-2004, 10:22 PM
I have a 2000 blazers, 2dr 4x4, was driving about 45 mph at first for about a half hour, got on the highway, got up to 85 and heard this strange humming noise, thought it was POS in front of me, then I slowed down and humming got louder, the humming was in synch with driving speed, I would speed up humming would speed up, slow down, humming slow down and get louder, I pulled over scared hell out of me, didnt see anything wrong, so started driving again and noise came back, first it started like a grinding noise then when got up to 45 started to get the humming, I slowed down again after about 6 miles, doing like 25 and hear small grinding like brakes, but brake pedal is not vibrating, I was mostly gettting vibration in stearing wheel and gas pedel (would think it was tires, but pretty sure its not since didnt have a vibration a day ago, and I work at a tire shop) I was worried cause I had a 250 miles trip to make and I just started, so I just ignored it and after about 80 miles humming went away but now get slight metal grinding noise and cant figure out where, on both sides of car, sounds like coming from both front and back, took it to miechke, they told me it was rust on the inside of the rotor, do u think this could be the problem? The humming noise did not come back (really sounds like a plane) and I drove about 400 miles without no humming, just the slighty grinding, also the grinding goes away when I turn on 4x4, and almost feels like I am pulling something or something is dragging underneather me, anyone have any ideas?

wehswarriorS-10
04-26-2004, 07:27 AM
could be a bad pinion bearing or something of that nature

quantos
07-11-2004, 06:38 PM
could be a bad pinion bearing or something of that nature
our truck had the same thing happen,it only did it in 2 wheel drive not 4x4.....it was the transfer case,luckily it was on warrenty.got a used one with 60k from saskatchewan government insurance.750.00cnd.

smahala1286
07-14-2004, 12:09 AM
I know this sounds stupid but that happend to our Astro we had and it ended up being the alternator.

Add your comment to this topic!