Electrical problems with a rover 75?


e_eriksson
12-01-2003, 12:14 PM
Hello!

My name is Erik and I' from Sweden and I was a proud Rover-owner until yesterday =/

This is my problem (since yesterday):

In some kind of way my car unlocks automatically whether I'm running the car or has it parked in the garage. The syndrome is this: The central lock unlocks all 4 doors, the directional indicators around the car flashes once and the light in the compartment lights up. In other words the car behaves just like someone has pressed the button on the key to unlock the car...and this happens randomly and several times every hour on the road.
First I thought it was the key that sent the signal randomly but that can't be the case because the car behaves the same way whether I have the key in present or not even near the car.

My solution today to not end up with my car unlocked at the parking lot is to lock the doors and remove one of the cables from the battery.

The car is a 2.0 diesel and I think it was made in 1999 or 2000.

Anyone got an idea? Very greateful for any help...

//Erik

__________________
e_eriksson(at)msn.com

mechy1barry
12-01-2003, 01:32 PM
check wiring/connections in front doors first.especially where they pass through door and pillar.

e_eriksson
12-02-2003, 02:13 AM
Will do! Shall I look för shortcuts and broken wires or is there something else to look for?

mechy1barry
12-02-2003, 01:19 PM
look for broken wires/poor connections.

johnxs1100
10-11-2017, 02:39 PM
Electrical problems with a rover 75? 2002 reg .in indicators working out side ok .dash no green lights to tell you your indicators are working.
removed dash stripped .tested ld lights. Some work some don't ....fitted all back to gether .no dater ?just your normal info.as of a old car. Car still runes ok. now . proberly fit another dash. as this car is a telephone. Sending dater 1000 of mints to the ECU.
CAR WILL NOT LOCK....I THINK THE RATS HAVE GOT IT.
I LOVE A CHALGEN BUT THIS AS BEAT ME.
any wizeds out there.lads that have work on rovers.in the last 17 years.
would like your help. VDC VEACAL DIRECT CONTROL ?I SEEN THIS ON THE DASH SIRCET BOARD .THANK FROM JOHN IN THE UK.http://staticaf.com/vbulletin/images/smilies/jerking.gif

W.smith
10-12-2017, 02:21 AM
Have you checked the plenum drain? And have you tried removing the negative lead off the battery for at least half an hour. When you rejoin, the system will re-boot itself and maybe get rid of all your problems.

Add your comment to this topic!