Our Community is 940,000 Strong. Join Us.


98 lesabre


kads
10-06-2016, 07:59 PM
just bought this 98 beauty with only 114,000 miles looks good inside and out.. the owner said after sitting 3 or 4 days the battery would be dead so, her mechanic took fuse out for the radio and no more problems.... i need the radio but can't find the fuse ? any help locating radio fuse .. manual says 9c and 8d but those fisses are still good/ any other place i can check? these fuses are on drivers side ,by parking brake

Tech II
10-07-2016, 12:00 AM
8D and 9C are the two radio fuses I see....there are two other fuse locations, under the hood(maxi fuses), and behind the kick panel on the passenger side...but those two locations, don't contain radio fuses....

make sure you are looking at the correct numerical and alphabetical slots....if fuses are there, did you check with a test light, both sides of the fuse(s)?

If fuses ok, does the Radio panel light up at all? Does it show stations changing, but no sound? Does it play a cd/cassette?

kads
10-07-2016, 07:22 AM
Thanks for your response.. Nothing lights up on the radio at all. I was told the mechanic pulled the fuse.. But the fuses are still there and appear to be good I will test tonight with a test light on the fuses as you said .. I'll swap out both of them fuses with know. Good ones .. He pulled the fuse because battery would drain in a few days if the car wasn't driven. She didn't drive it far or often thanks

kads
10-08-2016, 10:19 AM
for some reason the harness was not plugged into the back of the radio,, plugged it in and plugged in antenna. lights up but doesnt seem to turn on .. wont accept a c.d. or cassette.. wont go in.. any ideas

Tech II
10-08-2016, 12:28 PM
Seems like you are not getting the whole story here, if you were told a fuse was removed, and you find the radio not plugged in....

Here is a diagram for the power and ground in the harness to the radio to be checked out.......

http://i1208.photobucket.com/albums/cc376/gmtech7/LSradio.jpg

kads
10-08-2016, 12:58 PM
thanks when i took the radio out it made a rattling noise inside the radio ,so took it to a shop they said the caps were broken inside and thats why the battery was draining.. have you heard of that?? thanks again for the answers..

Add your comment to this topic!