Our Community is 940,000 Strong. Join Us.


1999 chev cavalier red brake lt on


j cAT
08-29-2014, 04:13 PM
A family member got this vehicle recently.I checked the brakes , bled and everything is working great .. no codes engine/abs . runs smooth . problem is the red dash brake light is on. checked the fluid switch on the master and the park brake no problems there. what I need is a wiring diagram and some input on what else would cause the red brake light to be on. 2.2L engine ..I also checked the 4 wheel abs sensors all good.

thanks ..

Tech II
08-29-2014, 05:57 PM
Only thing that turns the red brake light on is the level sensor in the reservoir, the ebrake, and I believe the ABS module....

If you just turn the key to on, don't crank, does the red light come on and then go out, or does it stay on solid? Or does it come onwhen the car is started or when put in gear? Have you disconnected the reservoir switch and the ebrake switch to see if the light goes out?

Have you checked your brake lights, especially the center stop light, to see if they are functioning? I know on some vehicles, don't know if the Cavalier does this, but if the center stop lamp is out, it turns the red brake light on....

j cAT
08-30-2014, 09:22 AM
Only thing that turns the red brake light on is the level sensor in the reservoir, the ebrake, and I believe the ABS module....

If you just turn the key to on, don't crank, does the red light come on and then go out, or does it stay on solid? Or does it come onwhen the car is started or when put in gear? Have you disconnected the reservoir switch and the ebrake switch to see if the light goes out?

Have you checked your brake lights, especially the center stop light, to see if they are functioning? I know on some vehicles, don't know if the Cavalier does this, but if the center stop lamp is out, it turns the red brake light on....

thanks for that info. the rear center brake light I will have to check.

the red dash brake light comes on with ignition on engine off and running. did the park brake / brake res. switch checks . also NO ABS codes with a ABS capable code reader.
my guess is this circuit is grounded out some where could be a ABS malfunction with in the ECBM.. I have to get a wiring diagram for this ..

gmtech1
08-30-2014, 11:02 AM
If you don't find any wiring issues, I have had to replace IPC's in these for the red brake light staying on. Not saying that's the issue here, just another nugget of info.

j cAT
08-30-2014, 12:47 PM
If you don't find any wiring issues, I have had to replace IPC's in these for the red brake light staying on. Not saying that's the issue here, just another nugget of info.

thanks . since you have corrected this , with that change sounds like a good possibility.

Add your comment to this topic!