Our Community is 940,000 Strong. Join Us.


98 sport won't start


oogle88jr
09-30-2013, 02:56 PM
My car has been running good until I was about to head somewhere. I started it but noticed my theft light was on so I shut off my car and tried to start it only it wouldn't start. All I got was a click and that was it. Need help on this. My dad looked at it and he said it couldn't have been my starter.

jdl
09-30-2013, 03:55 PM
If the starter motor won't even crank, Make sure the battery has a full charge and connections clean and tight. According to my wiring info, your security system has no control over the starter motor.

If this is an automatic, did you try cranking in neutral?

oogle88jr
09-30-2013, 03:59 PM
Battery has a charge and checked all fuses. Tried several times to start it and everything had power but now nothing comes in. Even that clicking noise doesn't come on.

shorod
09-30-2013, 11:22 PM
If it were a weak battery the starter relay would likely click several times in rapid succession. The single click would suggest either a failed starter motor assembly or an issue with the wiring, such as a loose or dirty connection.

Carefully inspect the connections at the battery. If your truck has the aftermarket temporary clamp on battery terminals, those should be suspect. You can also use a test light or multimeter to determine if you are getting a good activation signal to the starter relay when the key is turned and held to the Start position. If not, try as JDL suggested above and see if the truck will start with the gear selector in Neutral.

If I'm interpreting your last post correctly, nothing turns on with the key now. That still causes the battery cable connections to be suspect along with the ignition switch.

-Rod

oogle88jr
09-30-2013, 11:52 PM
Took to mechanic and was told it was my battery cable corrosion inside cable. He recommended I change it before it happens again

Add your comment to this topic!