Our Community is 940,000 Strong. Join Us.


97 2.2 overheating but fan running


comet240
05-13-2013, 11:19 AM
hi my mother was driving her 97 cav today and it was over heating I topped it off with water filled it up let it run then put cap on and checked fuses and relay

the fan comes up but its running constant and its not cooling the rad down its gone past the safe zone markings

whats causing that?? water pump isn't leaking and the heat works through the heater core as I told her to run the heat and have fan blow but it didn't cool car either

what would be wrong?

could it be the thermostat not opening? I know sensor is working as it goes up slowly and after a while hits H past the red zone

comet240
05-13-2013, 12:21 PM
also I tried running the car with the rad cap off so doesn't build pressure and while idling it doesn't go past half so fan never kicks in and doesn't go up

so I putting cap back on to see if it builds up and goes to H

but there is no water in the oil

but my question is it normal for water to drip from the muffler from the drain hole at back as I got puddle on ground

jamesslcx
05-25-2013, 03:19 PM
Comet, have you fixed it yet?

SleepyHead98
05-25-2013, 06:02 PM
Take a look at your plugs, if they have colored residue (IE the color of your coolant), have vapor coming out the back( You said water puddle... yikes), smells like coolant outside when car running, its probably head gasket. I got a cheap fix, did it on my car, put over 7k on it so far. my honest mechanic dot com /articles/blown-head-gasket-2.shtml .

If you really want to be sure its head gasket, get a comp gauge, but even those are not 100 percent for sure. If you have cyls reading outside of 10% of eachother then that cyl is bad.

EDIT. I didnt mention TStat at all. If the heater is working, that means the Tstat is open.

Add your comment to this topic!