Our Community is 940,000 Strong. Join Us.


95 lesabre extremely rough idel


optrixx06
04-09-2013, 01:36 PM
i have a 95 lesabre that idles really rough. idles at about 1000 rpm when warmed up and doesnt drop below that. once accelerator is pressed, car runs great with a small amount of vibration but no noticeable loss of power. Just idles really rough. I have been doing the Ol' parts swap thing for a bit to no avail. I have changed IAC, EGR, lower intake manifold gaskets and upper intake manifold, ICM, all three of my coils, wires, plugs, FPR, and pcv. Maf seems to be working properly and all injectors are firing. No noticeable oil or coolant consumption. Have no idea where to go from here. HELP!!! Thanks.

mopar man
04-09-2013, 09:15 PM
do a compression check on the cylinders you could have a blown head gasket or check your 02 sensors

Tech II
04-09-2013, 09:17 PM
Any codes set?

Compression test?

Done a coil output test?

Run the car with the MAF disconnected?

Since it is a 3.8, disconnect one injector at a time, to see if you can isolate a cylinder.....

Blue Bowtie
04-11-2013, 06:45 AM
While all injectors may be firing, that doesn't mean that they are all delivering the same volume of fuel, and also doesn't mean that they are all providing a clean, conical spray pattern of atomized fuel instead of streaming. These problems are frequently only noticed at idle since air inlet velocities at higher engine speeds help atomize the fuel from streaming or dribbling injectors.

Add your comment to this topic!