Our Community is 940,000 Strong. Join Us.


97 2.2 Emission fail


comet240
12-20-2012, 04:26 PM
ok i just went in for an emssions and it failed yet no code issues to even consider it

HCPPm limit 66 reading 146
CO% limit 0.37 reading 0.58
NO ppmlimit 0505 reading 1537

thats at 40km/h

curb idl is
Hcppm limit 200 reading 123
CO% limit 1 reading 0.03
No ppm n/a n/a

now curb idle pass's but not the 40km

so what causes this

also this car was orginalyl outfitted for 1 02 sensor the 2nd 02 sensor was capped off as the org cat didnt have one

now when i put a brand new exhaust on it since i didnt have option for 2nd 02 sensor i capped off 02 sensor hole on the cat and when i ran it last year it over heated on the intake side of the cat turned red hot then i had to replace it and it also turned red hot
then i just bought a 2nd 02 sensor and had to find out where on the engine where gm capped off the 2nd o2 sensor plug and pluged it in but now i needed to emission it and it failed car never went on road since last year as i had anti theft on it stuck on

so is this problem the Cat? the Innova code scaner i have all it shows is the EPA flashing but rest are good

like i have brand new exhaust from front to back and 2 new o2 sensor

j cAT
12-20-2012, 06:09 PM
ok i just went in for an emssions and it failed yet no code issues to even consider it

HCPPm limit 66 reading 146
CO% limit 0.37 reading 0.58
NO ppmlimit 0505 reading 1537

thats at 40km/h

curb idl is
Hcppm limit 200 reading 123
CO% limit 1 reading 0.03
No ppm n/a n/a

now curb idle pass's but not the 40km

so what causes this

also this car was orginalyl outfitted for 1 02 sensor the 2nd 02 sensor was capped off as the org cat didnt have one

now when i put a brand new exhaust on it since i didnt have option for 2nd 02 sensor i capped off 02 sensor hole on the cat and when i ran it last year it over heated on the intake side of the cat turned red hot then i had to replace it and it also turned red hot
then i just bought a 2nd 02 sensor and had to find out where on the engine where gm capped off the 2nd o2 sensor plug and pluged it in but now i needed to emission it and it failed car never went on road since last year as i had anti theft on it stuck on

so is this problem the Cat? the Innova code scaner i have all it shows is the EPA flashing but rest are good

like i have brand new exhaust from front to back and 2 new o2 sensor

I had a chevy that was 16yrs old and had 380,ooomi on it and it produced 26 HC .

your excessively high readings to me say your running way too rich.


could be a diaphram torn .

if you replace the cat converter with a rich condition the vehicle will glow very bright red. that is the function of a cat to burn the unburned fuel .

could also be bad compression/plugs /wires/valves etc that would cause unburned fuel to get to the cats.


A PROPERLY RUNNING ENGINE WITH NO CAT CONVERTERS SHOULD GET MUCH LOWER READINGS THAN YOU HAVE.

comet240
12-20-2012, 07:18 PM
oh ic well from the one garage they said it is usually the thermostat sensor that tells the cars computer that its -40 out

but i had that replaced and i installed the down stream 02 sensor and it hasnt turned red
so thats why i thinking its damage the cat since it turned red hot from jsut idlying last year

comet240
12-21-2012, 05:35 PM
ah garage quit early by 2:30pm and wont be open till new year so they pissed me off
ugh

so no retest till then

Add your comment to this topic!