Our Community is 940,000 Strong. Join Us.


95 Metro no power


red39715
07-26-2012, 12:42 AM
The car starts fine. It sometimes takes a few seconds of turning the car over to get it started. I guess I should state that it is a 3cyl 5 speed. When you go to drive it there is no power. A hill I use to go up in 4th gear I now have to use 2nd gear. I have replaced the plug wires and it operates the same. If I take off each wire while it is running you can tell that cylinder was working. I have not checked the compression yet. I am thinking it might be the fuel pump. I'm going to also check the fuel pressure. Any other ideas out there?

Woodie83
07-26-2012, 05:14 AM
It's worn out, check your compression. Engine warm, all plugs out, throttle wide open. Factory is 200 psi, recommended minimum is 150 psi. Usually when they get hard to start, they're down around 120.

Jeff Collision
07-26-2012, 08:18 AM
As you said, check your compression and fuel pressure. In addition, check your fuel filter. If you have clogged sound, replace the filter.

Metro Mighty Mouse
07-26-2012, 12:14 PM
Might be a clogged catalytic converter as well. Easy way to check it is to loosen the exhaust where the cat bolts in and put something between the flanges to hold it open. It'll be loud but if your power returns then the cat was the issue.

red39715
07-26-2012, 11:00 PM
Rebuilt the engine less then 5000 miles ago. Removed the Cat also.

danielsatur
07-26-2012, 11:13 PM
Is the HP lost at the front wheels?
It could be as simple as a bad clutch.

tsc73
10-02-2013, 04:59 PM
Check the fuel filter also the fuel pressure regulator. The pressure regulator is an easy fix and its one of the top 3 problems of the 92 metro. The regulator only costs between $30-$40 . Just know it doesn't come with the spring. So clean the spring with a rust remover sold near the fuel treatment section of your auto store.

Add your comment to this topic!