Our Community is 940,000 Strong. Join Us.


Engine Hiccop


1534dover
06-18-2012, 06:37 PM
The last week or so my 1996 LaSabre has kind of made a hiccup, usually on accelerating, I think. It doesn't happen with any kind of regularity, about once on a ten mile trip. I don't think I can make it happen. Is this an engine or transmission problem? Something else?

imidazol97
06-18-2012, 10:27 PM
The last week or so my 1996 LaSabre has kind of made a hiccup, usually on accelerating, I think. It doesn't happen with any kind of regularity, about once on a ten mile trip. I don't think I can make it happen. Is this an engine or transmission problem? Something else?

If it's light acceleration and usually in 4th where the ignition system is under the greatest load..., I'd think about replacement OEM quality wires for the spark plugs and new spark plugs, the recommended AC Delco model. That is if the wires have more than 40K on them and the plugs the same or the plugs are another brand.

The hiccup reminds me of a miss where my plug would occasionally short to the metal guard around the snapon portion of the wire at the plug.

happydog500
06-20-2012, 01:48 AM
I agree with imidazol97.

I had the same thing and it turned out to be a broken spark plug. Wish I would of checked it before since I drove it like that for a year.

You might want to have it scanned, could be a problem with the air flow sensor or something like that. :)

Chris.

1534dover
06-20-2012, 01:52 AM
I had the engine codes read and they showed a problem with the air flow sensor. The mechanic fixed it. I could probably use the new wires and plugs, though.

Add your comment to this topic!