Our Community is 940,000 Strong. Join Us.


1995 Lesabre fails emission test


Amarc
06-04-2012, 09:17 PM
1995 Lesabre fails emission idle test. The idle HC limit is 200 and the car reads 272 and the idle CO limit is 1 and the car reds 2.9. all the other readings are fine. The car seems to idle smooth and runs fine. Any suggestions where I should start?

danielsatur
06-04-2012, 10:36 PM
How many miles are on this car?
How's the fuel economy?
Is there a CEL on?
Is there a tune up history?

Start with a good Tune up:
1) New air filter, fuel filter, and PCV valve.
2) Clean MAF sensor, throttle body, and IAC.
3) New plugs, wires, and a H20 sensor.
4) Do a back pressure test on your catalytic converter.

Tech II
06-05-2012, 07:47 AM
Do as Danilesatur says, couldn't hurt......in this case, you really need a scan tool, because from the readings, this car is running rich.......I mean it could be something as simple as a dirty air filter.......on the other end, could be an O2 sensor, injector, MAF, etc. .......so do the simple thing, like a tuneup first.....

Of course, it all depends on where you live, too......in my state, if you fix this yourself, then go for a restest and fail, you are going to pay for another test.....if you go to a garage, they have a form they must fill out stating what the problem was and what the fix was....if you do go to a garage, make sure they have a gas analyzer to verify the fix.....

danielsatur
06-05-2012, 12:51 PM
Make sure your car is at normal operating Temp before your inspection, a cold car is going to have poorer emission.

Amarc
06-11-2012, 02:46 PM
The car has 205000 Km. Did as you suggested. Cleaned MAP sensor. Replaced plugs (they had 45000 Km on them). Replaced air filter (it had 50000 Km) and replaced the O2 sensor (still had original there). The curb idle HC went from 272 to14 and the CO went from 2.90 to 0.00 Everything passed with flying colors. Thanks for the advice.

Add your comment to this topic!