Our Community is 940,000 Strong. Join Us.


2004 chevy cavilier not running


jesterjoe
02-25-2012, 05:14 PM
i have 2 questions, when i plug in a autoscanner to my car it wont power on.....but when plugged into any other car it works fine. is there a fuse or something that runs the actual plug in.......

second question the car is not getting fuel it keeps dying but when i jacked up the car and beat on the bottom of the gas tank the fuel pump started working just fine again i dropped the car off the jacks drove it around the block it worked fine again until i moved it into the garage it seems to be draining all the power out of the battery when u try to start it after this problem occurs could this be a for certain the fuel pumps bad?

jamesslcx
02-25-2012, 07:10 PM
jesterjoe did you turn your ignition switch on after you plugged in your scanner? It really sounds like you have a bad fuel pump, sometimes jarring them will get them working again for a while.

jesterjoe
02-25-2012, 07:55 PM
yea i turned the key over on the car when scanner was plugged in like i said it worked on every car but mine so i did not know if i blew a fuse......... and i will replace the fuel pump

jamesslcx
02-25-2012, 09:19 PM
Jesterjoe that's very strange the scanner couldn't connect to your car, along with the fuse check the connector in your car for separated or bent pins just to be on the safe side and work from there. Let us know and good luck.

gmtech1
02-25-2012, 11:35 PM
Power for the ALDL connector is usually the same fuse for the cig lighter.

Mangoamerican
03-11-2012, 01:46 AM
check the ground going to the engine block.

Add your comment to this topic!