Our Community is 940,000 Strong. Join Us.


97 Cav does it have 2 O2 sensors?


comet240
12-14-2011, 10:24 AM
hi i totally lost

i read that all 96 cars have a down stream o2 sensor well my 97 doesnt and so doesnt my 97 sunfire when i replaced whole exhaust on the 97 cav it turned red hot i plugged the port for the o2 sensor and the org cat for the 97 sunfire and cav dont have a 02 sensor for the cat now on the top of the engine is the plug for the o2 sensor for the cat if i have to replace exhaust on the 97 sunfire do i need to put a o2 sensor in are they different cats now from 97 ?

and if i put a o2 sensor in the port on the 97 cav will it make it run as its stuck in theft mode but will that stop it from turning red hot when it does run again

cuz i confused i thought all 96 and up used 2 o2 sensors

comet240
12-14-2011, 02:28 PM
oh on top of it using the innova scan tool
on my 98 sunfire i get at the bottom of the live data for OBDSUP i get OBD2
on my 2004 cav i get OBD & OBD2
on my 97 cav and 97 Sunfire i get NO OBD

what does it mean and is that why i dont have a rear o2 sensor?

GuyWithCavalier
12-14-2011, 08:17 PM
oh on top of it using the innova scan tool
on my 98 sunfire i get at the bottom of the live data for OBDSUP i get OBD2
on my 2004 cav i get OBD & OBD2
on my 97 cav and 97 Sunfire i get NO OBD

what does it mean and is that why i dont have a rear o2 sensor?

maybe somebody removed it...?

Because my 99 Cav has two O2 sensors:
One at the front screwing in off the exhaust manifold,
and one *behind the Cat, i.e., downstream.
A wire runs off that, back up to the engine compartment.

If somebody did a cheap replacement of the C-Converter or pipe, maybe they simply cut off the wires or unplugged them from wherever they go (onboard computer?)

comet240
12-14-2011, 08:23 PM
heck if i know i took off the 2nd o2 sensor off my 98 sunfire since its malfunctioning and stuck it on the 97 cav also it has the plug on the end of the connector just no wires i guess just so no dirt got in but nothing change didnt show HTR on the innova scan tool or nothing still cant get it out of auto theft mode

and weird how my 97 sunfire also doesnt have a 2nd one either if u look under uses just a regular CAT so its all confusing i tell ya lol

still dont know what OBDSUP and why it says NO OBD when these are obd cars lol

autojoe
12-16-2011, 08:59 AM
sunfire and cavalier 97 should have a 4 wire post catalyst 02 sensor.all it does is tell pcm catalyst efficiency.....so pcm knows how good the cat is working and will trigger check engine light and throw a code and not pass emissions test.

autojoe
12-16-2011, 09:03 AM
i think it is your scan tool.it is obd 2.A bad post cat 02 will not cause cat to turn red.cat is plugged.a damaged cat needs replaced.a missfire will damage a cat or too rich of a condition.

comet240
12-16-2011, 01:53 PM
ya see thats what i mean i thinking the coolant sensor was saying the garage said it probably fault and told the computer its -40 out when its +15 out and pushing more fuel in as they were both 2 brand new cats i put in and the both turned red hot on the back of the cat not the front part

but my other question is this car never used a 2nd 02 sensor yet it has the plug for it and its a 97 so how is that possible it doesnt need one? and if i spend the 90 bucks for the 02 sensor will it help or car doesn need it?

autojoe
12-16-2011, 07:36 PM
it was manufactured with one....are you original owner?

comet240
12-17-2011, 10:05 AM
no i not org owner
the 97 sunfire and 97 cav both had org same cats where there is no plug for a cat and both cars have a plug in the 2nd os2 sensor socket to close it off from dirt

thats why i wondering whats up wit that

Add your comment to this topic!