Blower Motor out again

10-01-2011, 09:21 PM
Hi guys,
Got a question. I have a 2008 cannon crewcab with the 5 cyclinder. On a previous post I was telling how the blower motor switch did not work on the 3rd speed. I was told the resistor was probably bad so I replaced it and its worked fine since, for about there weeks. Today I've been driving the truck most of the day. I get in a few minutes ago, start the truck, put it in third speed, and it doesn't work again. Whats up with that. I got it from the dealer. It is an ac delco brand. Any suggestions on whats wrong. It works now the same as before. All speeds work but third speed. I would appreciate any advice. Fiserman :uhoh:

10-02-2011, 02:51 PM
Take a look at the terminals inside the connector at the resistor, make sure they are not burned or spread out.

10-02-2011, 09:24 PM
Got in truck this morning and speed no.3 started working. That is the same thing the original factor resister did before it went out. I haven't pulled it out to check it as you suggested but I will. But could there be anything else I should look for. Thanks for information. Fiserman

Add your comment to this topic!