Our Community is 940,000 Strong. Join Us.


my 92 3 banger won't warm up


atjunkie
09-25-2011, 07:51 AM
After rebuild in cold temps I can let this thing idle for 15 minutes and she's still not warm. Changed therm. no help. I just dont get it??

Mark SS
10-23-2011, 10:57 PM
You may have a air pocket, try putting the nose up hill and take the cap off and let it run it should come out. You will need to add more coolent. Also make sure the you put the thermastat in correctly I know it sounds stupid but my wife had a car that someone put in upside down and and it would not get warm. After I put a new one in the right way it did fine.

brivers
10-29-2011, 12:14 AM
I've heard this air pocket theory a few times now and I think that using it as a diagnosis for a problem is Bull. If you start with an empty system, put coolant in until its full. Wait until the thermostat opens and top it off. Put the cap back on and leave it. If there is any air trapped it will come out after a few warm ups and cool downs, PERIOD. Your overflow tank also needs to have coolant in it.
As to your car not warming up, ( unless you live in arctic weather conditions) you need a thermostat. The one in your car, new or old, is not working. If you're not getting heat to your heater, then you have a different problem.
Last thing. If you put a thermostat in backwards your car will overheat, no doubt.

Woodie83
10-29-2011, 04:55 AM
I've seen it happen.

Mark SS
10-30-2011, 08:27 PM
It could also be a stop up heater core. As for the thermostat My wife's Altima has 2 thermostats the lower one was the one put in backwards and it did not overheat it just would not get warm. They were replaced at the dealership the first time. I went to replace them and I saw this and asked a local shop who said that it was wrong. That is not to say that your's is in backwards.

Add your comment to this topic!