Our Community is 940,000 Strong. Join Us.


Clutch Problems - 93 Stealth R/T


$STEALTH$
06-24-2010, 08:04 PM
So i just got my car fixed and running. I drove it home from the shop and i noticed that my clutch is slipping? It has a brand new clutch. Pressure plate and throw out bearing... I cant seem to figure out why it is slipping. But its slipping extremely bad. By the time i got home (which is about a 10 mile drive) i had nothing. I couldn't even move the car. I could smell the clutch.

Car has a brand new transmission so it cant be that. It goes through all the gears. When i started out driving it today from the shop. It really didn't have any slip at all. Until i got on it a little. Even then it still picked up speed pretty damn fast like it almost should.

By the time i got into town which is about 2 miles into the drive. I still had some grab but i noticed the rpms starting to rise like it was an automatic car. Slips that bad...:eek7:

Could you make a suggestion on what it is? And or what i should do

Stealthee
06-25-2010, 05:03 PM
Clutch pedal needs adjusted.

$STEALTH$
06-25-2010, 08:49 PM
So in other words i need to bleed the clutch more?

Stealthee
06-25-2010, 11:07 PM
No. If the clutch wasn't bled enough you'd have a spongy pedal. The pedal needs adjusted.

http://www.3si.org/forum/f58/video-tutorial-adjusting-clutch-pedal-non-turbo-3s-hd-720p-video-454086/

$STEALTH$
06-26-2010, 12:27 PM
I tried starting out doing what the video told me. I try pushing with just my thumb mucsle and i get resistance right away. Its hard from the start. I noticed when i drive it. When i let it all the way out is when it starts to catch. If i could just make it to where it catches halfway from the floor that would be great. Is that what this movie shows pretty much?

Stealthee
06-26-2010, 04:00 PM
I will just reitterate, watch the video.

Add your comment to this topic!