Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Pontiac > Grand AM
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-25-2008, 01:38 AM   #1
BlackZodiac
AF Newbie
 
Join Date: Apr 2004
Location: Home
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
97 GA wiring question/ Tranny question

Hey all. I'm in the process of putting a new engine into my 97 GA and have a quick question. In the loom that contains the connectors for the coil module I have a red connector with two wires (Grn/Wht, and Tan) Can someone PLEASE remind me where this connects!! I've had to rework a bit of the wiring already due to the fact that the new engine is out of a 96 or 97 chev lumina. I'm just wondering what this connector is for and hopefully can figure out where its at on the new engine. ;0 If anyone could post some clear pics of the 97 GA se engine bay that would be extremely helpfull as well.

Thanks

Also the neutral safety switch is in a different position on the new transmission..... connectors are turned more towards the firewall than the old one. How big a deal is it to move this? Or should I just try and make the harness reach through a bit of manipulation and leave the switch as is?
__________________
2003 Caravan SE
BlackZodiac is offline   Reply With Quote
Old 10-26-2008, 11:17 AM   #2
xeroinfinity
out saving the world
 
xeroinfinity's Avatar
 
Join Date: Jul 2005
Location: Yourtown, Indiana
Posts: 10,698
Thanks: 8
Thanked 18 Times in 18 Posts
Re: 97 GA wiring question/ Tranny question

DOnt have any pics of the engine bay but here is a link with wire diagrams.

Also I would try and make the park neutral safty switch work with out moving. Unless the shift cable doesnt hook up right then it might need turned around, but these trans are identical other wise, both are 4T60E.
__________________
1999 Grand Am SS 3.4 OHV
xeroinfinity is offline   Reply With Quote
Old 10-26-2008, 11:44 PM   #3
BlackZodiac
AF Newbie
Thread starter
 
Join Date: Apr 2004
Location: Home
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 97 GA wiring question/ Tranny question

Ok... so I got the connector figured out. Just had to open my eyes.

Also I got the transmission connectors where they needed to be.... but now I have a new problem..... actually two. When I turn the key ahead the reverse light is lit even though it is in park. How can this be adjsuted?
Second problem is that I can't get the shifter to move out of park! Even though I'm pressing the brake it doesn't appear to be releasing the lever.

Any ideas?
__________________
2003 Caravan SE
BlackZodiac is offline   Reply With Quote
Old 10-27-2008, 08:04 PM   #4
xeroinfinity
out saving the world
 
xeroinfinity's Avatar
 
Join Date: Jul 2005
Location: Yourtown, Indiana
Posts: 10,698
Thanks: 8
Thanked 18 Times in 18 Posts
Re: 97 GA wiring question/ Tranny question

Sounds like the park neutral safty switch is out of adjustment.
Thier should be a lever on the trans to release the shift cable.
Loosen the cable, and try and move the shifter to neutral. Then put the trans in neutral by moving the shift lever manualy on top of the trans.
Now tighten up the cable lever to lock it into place.

If it wont move to neutral on the console shifter, after the above, then your brake/shift interupt solenoid could be bad or not getting power. Could also be a bad PNS switch.
__________________
1999 Grand Am SS 3.4 OHV
xeroinfinity is offline   Reply With Quote
Old 11-03-2008, 09:40 PM   #5
BlackZodiac
AF Newbie
Thread starter
 
Join Date: Apr 2004
Location: Home
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 97 GA wiring question/ Tranny question

OK... got that problem fixed too. I popped the shifter cable off the tranny lever and then realised that the cable was too short to reach the park position of the lever.... duh. So the tranny was actually in reverse and the shifter was in park. Hence the reason why I couldn't get it to realease the shift interlock. Fixed the mounting bracket for the shifter cable to accomodate and voila! Feel like a dumbass....

Got her full of fluids and running good now though. Only one more bug to work out.... Exhaust manifold flange doesn't mate up with the flange on the down pipe so I have to do a little modifying there. Will be back on the road real soon.

Thanks for the advice xeroinfinity. Much appreciated.
__________________
2003 Caravan SE
BlackZodiac is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Pontiac > Grand AM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 11:47 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts