Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Dodge > Ram Pickup | Ram SRT10
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 07-10-2005, 02:25 AM   #1
lbrandt
AF Newbie
 
Join Date: Jul 2005
Location: Merriam, Kansas
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Question 1998 Ram Oil Pressure Drop

OK, first of all, I just wnat to say that my problem is probably my fault. I am an idiot. I got out on the freeway from a store and didn't realize the automatic selector lever was in 2nd gear. I drove for about 10 min @ 70 MPH before I noticed my RPM were really high. (duh!) I know, I know, I've been beating myself up about it.

Now I have rod knock and at low RPMs the Oil Pressure drops to 0. I changed, the oil pump thinking I had screwed it up, but it still has the same problem.

It actually remains good until the truck gets warmed up, THEN the problem starts...

Ay Ideas?? I'm at a loss. I know my way around an engine fairly well, but the oil pump is the only thing I can think of.

There WERE a good bit of metal flecs in to pan and in the sump intake screen (I cleaned it out while I was in there), could've maybe done some serious damage (hopenot, fingers crossed).

Thanks in advace for any advice.

~L
lbrandt is offline   Reply With Quote
Old 07-11-2005, 08:32 PM   #2
Blylock
AF Newbie
 
Join Date: Jan 2004
Location: rochester
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1998 Ram Oil Pressure Drop

Quote:
Originally Posted by lbrandt
OK, first of all, I just wnat to say that my problem is probably my fault. I am an idiot. I got out on the freeway from a store and didn't realize the automatic selector lever was in 2nd gear. I drove for about 10 min @ 70 MPH before I noticed my RPM were really high. (duh!) I know, I know, I've been beating myself up about it.

Now I have rod knock and at low RPMs the Oil Pressure drops to 0. I changed, the oil pump thinking I had screwed it up, but it still has the same problem.

It actually remains good until the truck gets warmed up, THEN the problem starts...

Ay Ideas?? I'm at a loss. I know my way around an engine fairly well, but the oil pump is the only thing I can think of.

There WERE a good bit of metal flecs in to pan and in the sump intake screen (I cleaned it out while I was in there), could've maybe done some serious damage (hopenot, fingers crossed).

Thanks in advace for any advice.

~L
if you hosed some bearings, you will lose massive oil pressure
__________________
1998 Ram 1500 SLT 4x4
5.9L
Dynomax Performance Dual Exhaust
KN cold air intake
Bosch +4 Platnum Plugs
180 Degree Thermostat

I would suggest to anyone with a Ram to convert to a performance exhaust, especially if towing alot.
Blylock is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Dodge > Ram Pickup | Ram SRT10

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:56 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts