Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Dodge > Caravan | Voyager
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 10-31-2017, 01:57 PM   #1
_TAZ_
AF Newbie
 
Join Date: Oct 2017
Location: Altamonte Springs, Florida
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
ETC light on, won't start.

2008 Dodge Grand Caravan 3.3L 250,000Miles (old compnay van, been rode hard and put away wet)

started having P0305 #5 Misfire code.
changed plugs, no change, ran like 3 legged dog.
went to try plug wire, but they didn't have any. put new coil pack on and still #5 misfire running horrible. Driving to next parts store to get plug wires, ETC starts flashing, then solid. Cresting a hill it looses all power and dies..

Have it towed back to the office, was going to look at ETC and when I took the intake hose off water came out. took off ETC and puddle of water. looks kinda rusty. (no this van isn't from Houston, and didn't go mudding in it. That's next weekend)

this is my first time working on Dodge 3.3 don't know why there would be water up there.
_TAZ_ is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Dodge > Caravan | Voyager

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:55 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts