Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Mitsubishi > General Discussion
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 08-15-2020, 05:38 PM   #1
pryornfld
AF Regular
 
Join Date: Jun 2004
Location: Makinsons
Posts: 204
Thanks: 0
Thanked 0 Times in 0 Posts
2014 Mitubishi Outlander Starting Issues

Hello All,

I'm having issues with my Outlander starting. It was fine two days ago but now all it does is make a clicking sound similar to a machine gun. Put battery on charger and low voltage. Let it charge and put in car overnight. Went to start same thing. Today I put a different battery in and will try starting again tomorrow. So my question is:
Do I have a phantom current drain or just a bad battery? Looks like alternator is fine since when running I get 14.4v on battery.
Any thoughts?:runaround
pryornfld is offline   Reply With Quote
Old 08-16-2020, 09:19 AM   #2
aleekat
AF Enthusiast
 
Join Date: Dec 2001
Location: clarksville, Tennessee
Posts: 1,486
Thanks: 12
Thanked 159 Times in 156 Posts
Re: 2014 Mitubishi Outlander Starting Issues

Put a voltmeter on it when cranking. My guess is your battery is toast.
How old was the battery?
__________________
Post back, that's what makes Forums Work.
aleekat is offline   Reply With Quote
Old 08-16-2020, 05:20 PM   #3
pryornfld
AF Regular
Thread starter
 
Join Date: Jun 2004
Location: Makinsons
Posts: 204
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 2014 Mitubishi Outlander Starting Issues

I tried two batteries, one that was only 4 months old and it done the same to both batteries. Something is draining the batteries so I'll bring to garage as I dont have time myself to dig into it too much. But any quick checks more than appertained
pryornfld is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Mitsubishi > General Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:31 AM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts