Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Ford > Escort
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 05-16-2018, 10:27 PM   #1
hondadad2622
AF Newbie
 
Join Date: Apr 2011
Location: Fargo, North Dakota
Posts: 29
Thanks: 3
Thanked 0 Times in 0 Posts
1999 Escort SE-Basically no air through vents

Changed blower motor and resister thinking I had bad one of the two. Cleaned intake above blower motor attached. I had a couple of leaves. New fan works great just not through vents. The fan speeds work. The switch from ac to just fan, defrost, floor etc. does move. I can hear the "valves, switches" moving on command. There is just a faint flow of air at the different locations as I move the switch. The compressor is switching on as I move the switch to ac.

I have read posts here first as always. I know vacuum sounds like the next level but are there any other mechanical switches, relays, that could be causing the issue?

RECAP:

Fan switches to all speeds fine!
Fan resister new
Fan switch fine in all levels
Main Switch(vent,defrost,floor,ac,max ac) works great - I can see vacuum switch move as knob is turned.
Fuses All good
Air barely flows from vents when fan is on high! Verified fan working

What am I missing?

Thanks in advance for all the help!
Joe
__________________
Thanks from a dumb old dad! Like a bunny with that battery, I have to keep going and going and going on this car!

Last edited by hondadad2622; 05-21-2018 at 01:09 PM. Reason: Added Question
hondadad2622 is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks
Go Back   Automotive Forums .com Car Chat > Ford > Escort

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:39 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts