Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > GMC > Envoy
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 12-03-2020, 11:49 AM   #1
heymax
AF Newbie
 
Join Date: May 2004
Location: Wells, Maine
Posts: 29
Thanks: 4
Thanked 0 Times in 0 Posts
Fan switch issue 2006 Envoy

It all started when I lost #5. Now 1 thru 5 don't work. I replaced the resistor and still nothing. When you do switch to 5, you can hear the resistor clicking. I have checked all fuses. I thought it could be the switch but it clicks the resistor. In the last couple of weeks the fan was intermittent. No clue.
heymax is offline   Reply With Quote
Old 12-03-2020, 11:54 AM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,719
Thanks: 16
Thanked 346 Times in 340 Posts
Re: Fan switch issue 2006 Envoy

Ok, so do you have power and ground at the blower motor?
__________________
maxwedge is offline   Reply With Quote
Old 12-04-2020, 10:09 AM   #3
heymax
AF Newbie
Thread starter
 
Join Date: May 2004
Location: Wells, Maine
Posts: 29
Thanks: 4
Thanked 0 Times in 0 Posts
Re: Fan switch issue 2006 Envoy

Maxwedge, Yesterday, I had to go to the store and the blower started. It works on 1 thru 4 but 5 still doesn't work even though I replaced the Resistor. I'm definitely leaning toward the switch itself as the culprit. Still confused.
heymax is offline   Reply With Quote
Old 12-04-2020, 11:11 AM   #4
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,719
Thanks: 16
Thanked 346 Times in 340 Posts
Re: Fan switch issue 2006 Envoy

Look at the connector on the relay/resistor, they typically over heat and can burn the contacts.
__________________
maxwedge is offline   Reply With Quote
Old 12-04-2020, 12:19 PM   #5
heymax
AF Newbie
Thread starter
 
Join Date: May 2004
Location: Wells, Maine
Posts: 29
Thanks: 4
Thanked 0 Times in 0 Posts
Re: Fan switch issue 2006 Envoy

The plug at the resistor is fine. No signs of melting or overheating.
heymax is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD

Go Back   Automotive Forums .com Car Chat > GMC > Envoy

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:41 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts