Automotive Forums .com - the leading automotive community online! Automotive Forums .com - the leading automotive community online!
Automotive Forums .com - the leading automotive community online! 
-
Latest | 0 Rplys
Go Back   Automotive Forums .com Car Chat > Chevrolet > Caprice
Reply Show Printable Version Show Printable Version | Email this Page Email this Page | Subscription Subscribe to this Thread
 
Thread Tools Search this Thread
Old 02-21-2010, 10:04 PM   #1
jsb8097
AF Newbie
 
Join Date: Feb 2010
Location: Montgomery, Illinois
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation 1989 caprice classic

Why on my 89 caprice would I not have power to my steering column? I have lights, so I know I have power in the car. However I don't have my radio, nor turn signals, when I turn the car to the on position nothing happens. Like there is no power to the column. Is there some sort of ignition relay on the car? If so where is it? I have "hot wired" it with a wire from the fuse box to the pink wire on the column and everything worked, however that was short lived and now that doesn't work anymore. Before this happened the car would sometimes die at a light, but fire right back up. I have replaced the starter, ignition switch, and it has a newer battery. Any help is appreciated!!
jsb8097 is offline   Reply With Quote
Old 02-22-2010, 10:31 AM   #2
maxwedge
A990 racer
 
Join Date: Mar 2002
Location: Chestertown, New York
Posts: 16,683
Thanks: 16
Thanked 341 Times in 335 Posts
Re: 1989 caprice classic

You need a wiring diagram to track down the source of power, there is no relay, ther may be fusible links at the harness off the starter, not sure. Autozone.com, repair guides may have some basic diagrams.
__________________
maxwedge is online now   Reply With Quote
Old 02-22-2010, 02:24 PM   #3
jsb8097
AF Newbie
Thread starter
 
Join Date: Feb 2010
Location: Montgomery, Illinois
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1989 caprice classic

Thanks for the reply, I am pretty sure this is nothing off the starter but I will double check. I have looked at the wiring diagrams on Autozone's website, however I can't find anything that jumps out at me. Still on the hunt, thanks again!
jsb8097 is offline   Reply With Quote
Old 02-26-2010, 09:54 AM   #4
caffeineaholic
AF Regular
 
caffeineaholic's Avatar
 
Join Date: Mar 2009
Location: Phoenix, Arizona
Posts: 108
Thanks: 0
Thanked 0 Times in 0 Posts
Re: 1989 caprice classic

I agree with maxwedge, be sure to check each fuse and all of the relays (if you now how to check relays). Also, perhaps something is wrong with the ignition lock cylinder -- maybe it has an intermittent or loose connection? Another possibility may be a loose ground connection.
__________________
1985 Chevy Caprice small-block V8 305ci (5.0L) - 4-Barrel Q-Jet (E4ME) - 700R4 - 115k+ mi. - resonator and A/C components deleted.
Driven in severe weather most of the year (Arizona 100+ degrees during summer heat or in wet weather especially in harsh monsoons). About 30/70 highway/city driving.
caffeineaholic is offline   Reply With Quote
 
Reply

POST REPLY TO THIS THREAD


Bookmarks

Tags
1989, caprice, chevy, power, relay
Go Back   Automotive Forums .com Car Chat > Chevrolet > Caprice

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:10 PM.

Community Participation Guidelines | How to use your User Control Panel

Powered by: vBulletin | Copyright Jelsoft Enterprises Ltd.
 
 
no new posts